summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-30 11:11:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-30 14:53:50 +0100
commitd09ef9212b8d8e4c4537d6afe844a413d4d6fd74 (patch)
tree95514b8c4eea59211cdcfc82ae3b55ad11efe354 /dev-python/pytest
parentx11-misc/redshift: Python 3.5, REQUIRED_USE (bug #601234) (diff)
downloadgentoo-d09ef9212b8d8e4c4537d6afe844a413d4d6fd74.tar.gz
gentoo-d09ef9212b8d8e4c4537d6afe844a413d4d6fd74.tar.bz2
gentoo-d09ef9212b8d8e4c4537d6afe844a413d4d6fd74.zip
dev-python/pytest: Bump to version 3.0.4
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-3.0.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 12962e80efe9..d4c33d192cc4 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -3,3 +3,4 @@ DIST pytest-2.8.2.tar.gz 563955 SHA256 da2fc57320dd11f621d166634c52b989aa2291af1
DIST pytest-2.8.7.tar.gz 564943 SHA256 fc4c86be54fce08e4b85b646a736efa18c6cde7599c1d2919f4f74629e018baf SHA512 c7f626ceb599811caeab4646389a2c489dd22d766c772d6ca686098cef9a11dca47ef41a4a4b811110f358bca1f1a678b549b2adfea48317ae70cf166289b371 WHIRLPOOL c3849f1a9f62c05c1ce20593f32ee513aee87853914be4099503cd47b068732df99605a0a4db9a3a7add4ef2a85f4d5376acf1a2e3f48f5d438433f200cb6196
DIST pytest-3.0.2.tar.gz 727551 SHA256 64d8937626dd2a4bc15ef0edd307d26636a72a3f3f9664c424d78e40efb1e339 SHA512 38485c73f9df3c76b7b920b6957ffe4fbfd32ca0c46b73a53375a40586a482d270bf71b4457b68d48815d50ad173824b269ece255692ae0d1b13f0b1885ce54f WHIRLPOOL b6954a95e5f7d9b904c7543a09c2ef237c76c3a35bcd3e24c402a02aec3b35a19cdb952ac38af4ce43ae516cb5ac52023a0d91f2c587343265edd6d493145e8a
DIST pytest-3.0.3.tar.gz 731934 SHA256 f213500a356800a483e8a146ff971ae14a8df3f2c0ae4145181aad96996abee7 SHA512 ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af WHIRLPOOL 1883909fa23832e674cf912b1d88957dd435143dc124df5454c08ad02c8077473168f749ea94539c2c4b5cf08648a0bce7e90937bbdacd4bb69a4ccf15ecff23
+DIST pytest-3.0.4.tar.gz 733339 SHA256 879fee2c1fdbaacd1bf2c0047677c6dd4aee05b9c1e64330b34d130a584fa40d SHA512 f8ee3eb84b564419beb0bb78abbe0ffe44920b35c60021d2c77b2bc3a5ec13245768f848ccb2a1864d46fc343cdc4b2bc4a33d9459bf388f64ea2aea0d9c337d WHIRLPOOL e48fc51e1de0fe38eaebd21ea4249dd915ffbf190d1955bd9aa77976b9c692bd0a2541d8802e9e100603af647279740e6329491b0ce09ef898d102e78984b2bb
diff --git a/dev-python/pytest/pytest-3.0.4.ebuild b/dev-python/pytest/pytest-3.0.4.ebuild
new file mode 100644
index 000000000000..eb843209749e
--- /dev/null
+++ b/dev-python/pytest/pytest-3.0.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.29"
+COMMON_DEPEND="
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
+ >dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/logilab-common
+"
+
+python_prepare_all() {
+ chmod o-w *egg*/* || die
+ # Disable versioning of py.test script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_nose.py not written to suit py3.2 in pypy3
+ if [[ "${EPYTHON}" == pypy3 ]]; then
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v \
+ --ignore=testing/BUILD_nose.py \
+ || die "tests failed with ${EPYTHON}"
+ else
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -v testing || die "tests failed with ${EPYTHON}"
+ fi
+}
+
+python_compile_all(){
+ use doc && emake -C doc/en html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/en/_build/html/. )
+ distutils-r1_python_install_all
+}