summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/repoze-sphinx-autointerface
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface')
-rw-r--r--dev-python/repoze-sphinx-autointerface/Manifest1
-rw-r--r--dev-python/repoze-sphinx-autointerface/metadata.xml8
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.7.1.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/Manifest b/dev-python/repoze-sphinx-autointerface/Manifest
new file mode 100644
index 000000000000..3d4129088b3a
--- /dev/null
+++ b/dev-python/repoze-sphinx-autointerface/Manifest
@@ -0,0 +1 @@
+DIST repoze.sphinx.autointerface-0.7.1.tar.gz 7892 SHA256 97ef5fac0ab0a96f1578017f04aea448651fa9f063fc43393a8253bff8d8d504 SHA512 e2b2a41647a6e349bd33df8fcc08d2560f2a58b94a054bfcc9176cdcd97513ce78cc31945c7c12fd14f7906d21b23ba9c3fac0a06ed0c92ad7b89f73b5bf7ff4 WHIRLPOOL 2589c2ec262a9784d7a686550a748795a3892996d8c1efa05c300001471a273f801c085db394b80465ad1f0b2d7afbb680095d201cdbe4102447e8e4b62ffd05
diff --git a/dev-python/repoze-sphinx-autointerface/metadata.xml b/dev-python/repoze-sphinx-autointerface/metadata.xml
new file mode 100644
index 000000000000..266dfde2c0ad
--- /dev/null
+++ b/dev-python/repoze-sphinx-autointerface/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">repoze.sphinx.autointerface</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.7.1.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.7.1.ebuild
new file mode 100644
index 000000000000..732a0a95f6e9
--- /dev/null
+++ b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
+HOMEPAGE="https://pypi.python.org/pypi/repoze.sphinx.autointerface/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}