summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/routes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest3
-rw-r--r--dev-python/routes/files/routes-2.0-setup.py.patch38
-rw-r--r--dev-python/routes/files/routes-2.0-tests-py3.patch40
-rw-r--r--dev-python/routes/metadata.xml8
-rw-r--r--dev-python/routes/routes-1.13-r1.ebuild42
-rw-r--r--dev-python/routes/routes-2.0.ebuild61
-rw-r--r--dev-python/routes/routes-2.1-r1.ebuild73
-rw-r--r--dev-python/routes/routes-2.1.ebuild53
8 files changed, 318 insertions, 0 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
new file mode 100644
index 000000000000..756d2866ee7a
--- /dev/null
+++ b/dev-python/routes/Manifest
@@ -0,0 +1,3 @@
+DIST Routes-1.13.tar.gz 797539 SHA256 cc03d1a357cdb7af82e3909ee8ff93cb2b2afb48aca23bfde0117d6f49f624a7 SHA512 052b04e0ee803394ffe1675a075fb633e790fdcabf1ee012a73d0c4ef211b4d0b18be13f680537fe5f8424193245d0b4bb2d76a20b9e74707e73b25e076a9f6a WHIRLPOOL 7b83a24719ca2e051f9ba44ca712c10c2eca1590e1fc39afb731777de9c9bd73af4ef99868bf1e3dfa688ff38b9068f30311fe146973d9b55e1c61c501a08ebb
+DIST Routes-2.0.tar.gz 199195 SHA256 6e4eb6437a9def22e1344ee8f766d7795bedfe6f615d3ea138e4035d6fbd33f8 SHA512 a049efc8774ded555f597d165cc536891cf7c008a753cb0d3c44ebb5c763e117b5050c0ef68489e05f7d9bd6009250465cc56ce6954010a84ec9b3416f728e91 WHIRLPOOL b9e5e88071c32c51427cfb16ad16cdea4cdace35579b053ea4fd2e81b27858c163244fd7976e2bdf93ab79e413ba72e48b2db8fc6991a6199ef7ba56c9620e5a
+DIST Routes-2.1.tar.gz 179737 SHA256 ebf4126e244cf11414653b5ba5f27ed4abfad38b906a01e5d4c93d3ce5568ea3 SHA512 6dcea3e20d9883e29d6aea5949eef3b265094f46084234a15530c266930163918c6eb2ad00bb49cd9cbf947a0019c2d91a5455f997bc7a7e5b8c662837a728c2 WHIRLPOOL fbdb8e1a84aa2b1b8bf011aa68a31364f0fd48cabcaaf413274679f34e514283fbd8aac9497444b24f69f7d72393f38aeab5eeeb96659e3aae009ed2eebc4fbf
diff --git a/dev-python/routes/files/routes-2.0-setup.py.patch b/dev-python/routes/files/routes-2.0-setup.py.patch
new file mode 100644
index 000000000000..ec090f42fce5
--- /dev/null
+++ b/dev-python/routes/files/routes-2.0-setup.py.patch
@@ -0,0 +1,38 @@
+From 414ba660bccd3eed60f63cc8a1d117740065126f Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Wed, 25 Dec 2013 10:42:26 -0500
+Subject: [PATCH] Specify encoding when opening files in setup.py
+
+This resolves a UnicodeDecodeError when setup.py is invoked with a
+non-utf8 locale.
+
+https://bugs.gentoo.org/show_bug.cgi?id=495118
+---
+ setup.py | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index c76e869..9191f11 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,12 +1,14 @@
+ __version__ = '2.0'
+
+-import os, sys
++import io, os, sys
+
+ from setuptools import setup, find_packages
+
+ here = os.path.abspath(os.path.dirname(__file__))
+-README = open(os.path.join(here, 'README.rst')).read()
+-CHANGES = open(os.path.join(here, 'CHANGELOG.rst')).read()
++with io.open(os.path.join(here, 'README.rst'), encoding='utf8') as f:
++ README = f.read()
++with io.open(os.path.join(here, 'CHANGELOG.rst'), encoding='utf8') as f:
++ CHANGES = f.read()
+ PY3 = sys.version_info[0] == 3
+
+ extra_options = {
+--
+1.8.5.2
+
diff --git a/dev-python/routes/files/routes-2.0-tests-py3.patch b/dev-python/routes/files/routes-2.0-tests-py3.patch
new file mode 100644
index 000000000000..ec21799ba14f
--- /dev/null
+++ b/dev-python/routes/files/routes-2.0-tests-py3.patch
@@ -0,0 +1,40 @@
+Fix tests to work with random hash dicts.
+
+--- a/tests/test_functional/test_generation.py
++++ b/tests/test_functional/test_generation.py
+@@ -205,13 +205,14 @@ class TestGeneration(unittest.TestCase):
+ requirements={'month':'\d{1,2}','day':'\d{1,2}'})
+ m.connect('viewpost/:id', controller='post', action='view')
+ m.connect(':controller/:action/:id')
+-
+- eq_('/blog/view?year=2004&month=blah', m.generate(controller='blog', action='view', year=2004, month='blah'))
++
++ url = m.generate(controller='blog', action='view', year=2004, month='blah')
++ assert url == '/blog/view?year=2004&month=blah' or url == '/blog/view?month=blah&year=2004'
+ eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month=11))
+ eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month='11'))
+ eq_('/archive/2004', m.generate(controller='blog', action='view', year=2004))
+ eq_('/viewpost/3', m.generate(controller='post', action='view', id=3))
+-
++
+ def test_multiroute_with_splits(self):
+ m = Mapper(explicit=False)
+ m.minimization = True
+@@ -219,13 +220,14 @@ class TestGeneration(unittest.TestCase):
+ requirements={'month':'\d{1,2}','day':'\d{1,2}'})
+ m.connect('viewpost/:(id)', controller='post', action='view')
+ m.connect(':(controller)/:(action)/:(id)')
+-
+- eq_('/blog/view?year=2004&month=blah', m.generate(controller='blog', action='view', year=2004, month='blah'))
++
++ url = m.generate(controller='blog', action='view', year=2004, month='blah')
++ assert url == '/blog/view?year=2004&month=blah' or url == '/blog/view?month=blah&year=2004'
+ eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month=11))
+ eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month='11'))
+ eq_('/archive/2004', m.generate(controller='blog', action='view', year=2004))
+ eq_('/viewpost/3', m.generate(controller='post', action='view', id=3))
+-
++
+ def test_big_multiroute(self):
+ m = Mapper(explicit=False)
+ m.minimization = True
diff --git a/dev-python/routes/metadata.xml b/dev-python/routes/metadata.xml
new file mode 100644
index 000000000000..2c6bedd73313
--- /dev/null
+++ b/dev-python/routes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Routes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/routes/routes-1.13-r1.ebuild b/dev-python/routes/routes-1.13-r1.ebuild
new file mode 100644
index 000000000000..36483a4792cf
--- /dev/null
+++ b/dev-python/routes/routes-1.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+# Note: although setup.py states that tests require webtest,
+# it isn't used anywhere.
+RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/routes/routes-2.0.ebuild b/dev-python/routes/routes-2.0.ebuild
new file mode 100644
index 000000000000..5ca16711f526
--- /dev/null
+++ b/dev-python/routes/routes-2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
+ >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-tests-py3.patch
+ "${FILESDIR}"/${PN}-2.0-setup.py.patch
+)
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cp -r tests "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
+ fi
+
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/routes/routes-2.1-r1.ebuild b/dev-python/routes/routes-2.1-r1.ebuild
new file mode 100644
index 000000000000..55d3d993f8ed
--- /dev/null
+++ b/dev-python/routes/routes-2.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+# It appears there's an epidemic of missing testsuites coming out of github. Restrict for now
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+# Comment out patch for tests for now
+#PATCHES=( "${FILESDIR}"/${PN}-2.0-tests-py3.patch )
+
+# https://github.com/bbangert/routes/issues/42 presents a patch
+# for the faulty docbuild converted to sed stmnts
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ # The default theme in sphinx switched to classic from shpinx-1.3.1
+ if has_version ">=dev-python/sphinx-1.3.1"; then
+ sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
+ -i docs/conf.py || die
+ else
+ sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
+ -i docs/conf.py || die
+ fi
+ sed -e "s:changes:changes\n todo:" \
+ -i docs/index.rst || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cp -r tests "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
+ fi
+
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/routes/routes-2.1.ebuild b/dev-python/routes/routes-2.1.ebuild
new file mode 100644
index 000000000000..9859278ed071
--- /dev/null
+++ b/dev-python/routes/routes-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )"
+# It appears there's an epidemic of missing testsuites coming out of github. Restrict for now
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+# Comment out patch for tests for now
+#PATCHES=( "${FILESDIR}"/${PN}-2.0-tests-py3.patch )
+
+# The doc build possibly never built. Just know that the doc builds in
+# neither the previous nor this
+# https://github.com/bbangert/routes/issues/42
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r tests "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
+ fi
+
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}