summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-12-29 08:29:49 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-12-29 08:29:49 +0700
commitb1754d7ad8e53f7782dc873acaf99f8d2b99d04d (patch)
tree40ed6045006cce7d80e05aa2c04e89331169d6b6 /dev-python/sympy
parentkde-plasma: 5.8.5 version bump (diff)
downloadgentoo-b1754d7ad8e53f7782dc873acaf99f8d2b99d04d.tar.gz
gentoo-b1754d7ad8e53f7782dc873acaf99f8d2b99d04d.tar.bz2
gentoo-b1754d7ad8e53f7782dc873acaf99f8d2b99d04d.zip
dev-python/sympy: fix a wrong test
Bug: 603214 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/files/sympy-1.0-zeta.patch47
-rw-r--r--dev-python/sympy/sympy-1.0-r1.ebuild2
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/sympy/files/sympy-1.0-zeta.patch b/dev-python/sympy/files/sympy-1.0-zeta.patch
new file mode 100644
index 000000000000..43f54832c948
--- /dev/null
+++ b/dev-python/sympy/files/sympy-1.0-zeta.patch
@@ -0,0 +1,47 @@
+diff -r -U2 sympy-1.0.orig/sympy/functions/special/tests/test_zeta_functions.py sympy-1.0/sympy/functions/special/tests/test_zeta_functions.py
+--- sympy-1.0.orig/sympy/functions/special/tests/test_zeta_functions.py 2016-03-09 00:38:39.000000000 +0600
++++ sympy-1.0/sympy/functions/special/tests/test_zeta_functions.py 2016-12-28 23:25:19.370041561 +0700
+@@ -125,5 +125,5 @@
+ assert polylog(s, 0) == 0
+ assert polylog(s, 1) == zeta(s)
+- assert polylog(s, -1) == dirichlet_eta(s)
++ assert polylog(s, -1) == -dirichlet_eta(s)
+
+ assert myexpand(polylog(1, z), -log(1 + exp_polar(-I*pi)*z))
+diff -r -U2 sympy-1.0.orig/sympy/functions/special/zeta_functions.py sympy-1.0/sympy/functions/special/zeta_functions.py
+--- sympy-1.0.orig/sympy/functions/special/zeta_functions.py 2016-03-09 00:38:39.000000000 +0600
++++ sympy-1.0/sympy/functions/special/zeta_functions.py 2016-12-28 23:23:56.109047180 +0700
+@@ -245,5 +245,5 @@
+ zeta(s)
+ >>> polylog(s, -1)
+- dirichlet_eta(s)
++ -dirichlet_eta(s)
+
+ If :math:`s` is a negative integer, :math:`0` or :math:`1`, the
+@@ -272,10 +272,17 @@
+ @classmethod
+ def eval(cls, s, z):
++ from sympy import unpolarify
+ if z == 1:
+ return zeta(s)
+ elif z == -1:
+- return dirichlet_eta(s)
++ return -dirichlet_eta(s)
+ elif z == 0:
+- return 0
++ return S.Zero
++
++ # branch handling
++ if (1 - abs(z)).is_nonnegative:
++ newz = unpolarify(z)
++ if newz != z:
++ return cls(s, newz)
+
+ def fdiff(self, argindex=1):
+@@ -486,5 +493,5 @@
+ For `\operatorname{Re}(s) > 0`, this function is defined as
+
+- .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^n}{n^s}.
++ .. math:: \eta(s) = \sum_{n=1}^\infty \frac{(-1)^{n-1}}{n^s}.
+
+ It admits a unique analytic continuation to all of :math:`\mathbb{C}`.
diff --git a/dev-python/sympy/sympy-1.0-r1.ebuild b/dev-python/sympy/sympy-1.0-r1.ebuild
index 88544a984687..2015771ecfc1 100644
--- a/dev-python/sympy/sympy-1.0-r1.ebuild
+++ b/dev-python/sympy/sympy-1.0-r1.ebuild
@@ -51,7 +51,7 @@ pkg_setup() {
python_prepare_all() {
epatch "${FILESDIR}"/${P}-doc-makefile.patch
- epatch "${FILESDIR}"/${PN}-0.7.6.1-zeta.patch
+ epatch "${FILESDIR}"/${P}-zeta.patch
distutils-r1_python_prepare_all
}