summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tzlocal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tzlocal')
-rw-r--r--dev-python/tzlocal/Manifest2
-rw-r--r--dev-python/tzlocal/metadata.xml9
-rw-r--r--dev-python/tzlocal/tzlocal-1.1.2.ebuild27
-rw-r--r--dev-python/tzlocal/tzlocal-1.2.ebuild26
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/tzlocal/Manifest b/dev-python/tzlocal/Manifest
new file mode 100644
index 000000000000..0fbf54813a8b
--- /dev/null
+++ b/dev-python/tzlocal/Manifest
@@ -0,0 +1,2 @@
+DIST tzlocal-1.1.2.zip 22504 SHA256 4d9ddb8d5eab086e3a7c504c6e994ffa85df43e40da4d6be776218be051c677a SHA512 966b56af79238332dd3d6c730d1e0a8ab3c7caa06755d9fb148473297a6ac65133e9d554236a7d09672a663266e3214142d423c62ba3444558ae81a12d21a629 WHIRLPOOL f95f2d0e4cbeee955dbf6fdcdc928d6514c8a76446b6c52349341f54a06749c2c3fd1a25f487bcf989a11c03abe0b870305f87eee01fc0ac107070c1e5a3dbd1
+DIST tzlocal-1.2.tar.gz 16149 SHA256 438f122d684c951b22cb98aecc80fdb961b84e69542bf878c6b9a9419de09a8b SHA512 eb4d1f73983579e109249884d2a343c441942fb0d4dc76aed693c4a05100b10a2337d72794fdb9c0cd28c3b73e11dbd030bdf6dc2f75e57c958655219973c814 WHIRLPOOL 8f39abc1a07a27c4afa8116c8817a1ec37483d8f05291f29a23ea6cfaf2bb517fca7b0b8998c8d13183cc0f0b26bb718c1674c033af271460ed1add7e0ccf5d6
diff --git a/dev-python/tzlocal/metadata.xml b/dev-python/tzlocal/metadata.xml
new file mode 100644
index 000000000000..ba3614fc5729
--- /dev/null
+++ b/dev-python/tzlocal/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">tzlocal</remote-id>
+ <remote-id type="github">regebro/tzlocal</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tzlocal/tzlocal-1.1.2.ebuild b/dev-python/tzlocal/tzlocal-1.1.2.ebuild
new file mode 100644
index 000000000000..dd9a3bfc7ccb
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-1.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="mirror://pypi/t/${PN}/${P}.zip"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+
+python_test() {
+ unset TZ
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/tzlocal/tzlocal-1.2.ebuild b/dev-python/tzlocal/tzlocal-1.2.ebuild
new file mode 100644
index 000000000000..e21475019651
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+
+python_test() {
+ unset TZ
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}