summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/vcversioner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/vcversioner')
-rw-r--r--dev-python/vcversioner/Manifest1
-rw-r--r--dev-python/vcversioner/metadata.xml12
-rw-r--r--dev-python/vcversioner/vcversioner-2.14.0.0.ebuild18
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/vcversioner/Manifest b/dev-python/vcversioner/Manifest
new file mode 100644
index 000000000000..58a1f0aa08f4
--- /dev/null
+++ b/dev-python/vcversioner/Manifest
@@ -0,0 +1 @@
+DIST vcversioner-2.14.0.0.tar.gz 9015 SHA256 acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357c03b86 SHA512 0d474910f9d0f0dd0c0d0b824bcdf5da7bbb5d2b55691f18107bb0b8a237213a83d8f51f719d4761e1dae9db70e84ef8c264c388ec1995ed0a55a838575e377e WHIRLPOOL b146f1d008b635fc337c2256a7bb9bd0534ecd3a335c349a0518e36ee21e807de1b43ea52dd6a581fa4de64ad6cdb2dca53646051a93afe752a28d4a25bcbec8
diff --git a/dev-python/vcversioner/metadata.xml b/dev-python/vcversioner/metadata.xml
new file mode 100644
index 000000000000..6f3bf88d95dd
--- /dev/null
+++ b/dev-python/vcversioner/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">vcversioner</remote-id>
+ <remote-id type="github">habnabit/vcversioner</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild b/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
new file mode 100644
index 000000000000..5638db247708
--- /dev/null
+++ b/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use version control tags to discover version numbers"
+HOMEPAGE="https://github.com/habnabit/vcversioner"
+SRC_URI="mirror://pypi/v/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""