summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-26 17:53:52 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-26 18:33:59 +0200
commit7c9883a1c9b4b792309db5a39a10d7b2aea25af5 (patch)
tree9427f039adb64007c99d2f3e1f0e9f9723c7a9cd /dev-python/venusian
parentdev-python/radon: Tested on py3.5 & py3.6 (diff)
downloadgentoo-7c9883a1c9b4b792309db5a39a10d7b2aea25af5.tar.gz
gentoo-7c9883a1c9b4b792309db5a39a10d7b2aea25af5.tar.bz2
gentoo-7c9883a1c9b4b792309db5a39a10d7b2aea25af5.zip
dev-python/venusian: Fix running tests
Use 'setup.py nosetests' to run tests, as defined in tox.ini. This solves the problem of nosetests attempting to import files that fail to import by design.
Diffstat (limited to 'dev-python/venusian')
-rw-r--r--dev-python/venusian/venusian-1.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/venusian/venusian-1.0.ebuild b/dev-python/venusian/venusian-1.0.ebuild
index c47432880160..512b8aec4726 100644
--- a/dev-python/venusian/venusian-1.0.ebuild
+++ b/dev-python/venusian/venusian-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -22,9 +22,8 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )
- "
+ >=dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )"
python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
+ esetup.py nosetests
}