summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 11:12:50 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 11:29:20 +0100
commit49c59b1fde1c081e5c0ac9620fc2fd3fefcfb6e6 (patch)
tree3ca9654c6ef83d1798106d2d09e26e220ea3f6b2 /dev-python/virtualenv
parent[www-apps/drupal] Bump to 8.0.0_rc4 release - fixes bug 565814. Drop old beta... (diff)
downloadgentoo-49c59b1fde1c081e5c0ac9620fc2fd3fefcfb6e6.tar.gz
gentoo-49c59b1fde1c081e5c0ac9620fc2fd3fefcfb6e6.tar.bz2
gentoo-49c59b1fde1c081e5c0ac9620fc2fd3fefcfb6e6.zip
dev-python/virtualenv: Remove unnecessary dependency on pip & setuptools
Bundled dev-python/{pip,setuptools,argparse,wheel} cannot be removed, as we have a chicken and egg problem here. In the new virtualenv we need those packages to install them. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=566022 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/virtualenv-13.1.2.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/virtualenv/virtualenv-13.1.2.ebuild b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
index fcbcb8894aea..b760d8215fe4 100644
--- a/dev-python/virtualenv/virtualenv-13.1.2.ebuild
+++ b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
@@ -21,11 +21,9 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sp
SLOT="0"
IUSE="doc test"
-RDEPEND="
- >=dev-python/pip-7.1.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
+RDEPEND=""
DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
@@ -44,7 +42,7 @@ python_compile_all() {
}
python_test() {
- py.test -vvx || die "Tests fail with ${EPYTHON}"
+ py.test -v -v || die "Tests fail with ${EPYTHON}"
}
python_install_all() {