summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-04 17:11:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-04 19:04:12 +0200
commit6f067e7748ad737fa648f95416f28bacc3a103ae (patch)
tree02b79604736ad56c2e03567d7e6c222fdde7742e /dev-python/werkzeug
parentdev-python/html5lib: Fix deprecated imports (diff)
downloadgentoo-6f067e7748ad737fa648f95416f28bacc3a103ae.tar.gz
gentoo-6f067e7748ad737fa648f95416f28bacc3a103ae.tar.bz2
gentoo-6f067e7748ad737fa648f95416f28bacc3a103ae.zip
dev-python/werkzeug: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-1.0.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index e12f8d764d12..3b3f89108820 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,3 +1,4 @@
DIST werkzeug-0.16.0.gh.tar.gz 939220 BLAKE2B 08f77bfbb8703b25be00dba018e9aea16cb4a6977ff3906f636fe24b4e16662f7777584839c8e153532f32a0551281a6fb28bf618da5d5e6c42cdc6e8b391162 SHA512 78e7d2ccceb8764f92a3252b2ff670065a42fe2ad1d2b4631e05c107d2128f8f6f4090e32bd975526e4b5985dbbdbac22e9ad1514d14e88ecfb064483107d0ed
DIST werkzeug-0.16.1.gh.tar.gz 937876 BLAKE2B e5f962e9cab4a06a6f2d63ac35df896ed764377b458ccdc744800ffa5d2d456a836f0a7c4aef08b750b95904e955ce3b0241102d48bd28080e91fe29823e789e SHA512 52611b2e22b8af6b643471ca1df6e6f262067ef8882363768f21d9b0ee837aedd192c358a3a41788b2036d6c6cc0156043f1f5b8f6a04b2a701790b66837a62e
DIST werkzeug-1.0.0.gh.tar.gz 907492 BLAKE2B b81a3645d1228a7a2321f14d9093f77ac2cb620403008efb09b5f22b5b27297972d86adc307249828eda6dd2ca38a17ba1590cfc6ff47e7c8faddb34ffa0ba7a SHA512 bc6d61b078aebd92d79a68d2b040dc9cf0cb5a61fe9732861109324bd7f7be6e5fb9e2101f145429909d0e06a6435bd3b8d707022525c5236ba52776a315af2e
+DIST werkzeug-1.0.1.gh.tar.gz 907482 BLAKE2B d2dcdce8b1bcbb177b52b0915f2c0ac17d235dee3c77b23e81e4b35412d1f53a194d3c7c7f2a5c065ade99797effe72cc464cf6980b12c761a8a919338021660 SHA512 ba82120fb3e96e3a1334c6452d5ba1950fc016d2d147d643bbc2168ccec496f1dea799982ae8c578167155082c0bdbda5d56a23f64b4b6865f97e90e22df022e
diff --git a/dev-python/werkzeug/werkzeug-1.0.1.ebuild b/dev-python/werkzeug/werkzeug-1.0.1.ebuild
new file mode 100644
index 000000000000..f376383081ac
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
+#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="https://github.com/pallets/werkzeug/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # this test is very unreliable; it may fail randomly depending
+ # on installed packages
+ sed -i -e 's:test_no_memory_leak_from_Rule_builder:_&:' \
+ tests/test_routing.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv -x -p no:httpbin tests/test_routing.py || die "Tests fail with ${EPYTHON}"
+}