summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wheel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/metadata.xml8
-rw-r--r--dev-python/wheel/wheel-0.24.0.ebuild20
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
new file mode 100644
index 000000000000..be4417b944e1
--- /dev/null
+++ b/dev-python/wheel/Manifest
@@ -0,0 +1 @@
+DIST wheel-0.24.0.tar.gz 50597 SHA256 ef832abfedea7ed86b6eae7400128f88053a1da81a37c00613b1279544d585aa SHA512 9990e6bb6e42eebdac26ce75cee13e3b3da293520b2b25fad6dd328b920ce484bcf238ab7f9092d4ac565e26833b164b1ad5b8b258c824ff07daede127b17283 WHIRLPOOL faf13ddf756910558fd13d3b9eae399e488cd1938998c58a1ac3117aa7843480da5aab7c8454d67596cac8f524e23c4465e0ee9d2499a6af4afd2017c6b5314d
diff --git a/dev-python/wheel/metadata.xml b/dev-python/wheel/metadata.xml
new file mode 100644
index 000000000000..5f34195aa2ab
--- /dev/null
+++ b/dev-python/wheel/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">wheel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wheel/wheel-0.24.0.ebuild b/dev-python/wheel/wheel-0.24.0.ebuild
new file mode 100644
index 000000000000..9d7951f0b55c
--- /dev/null
+++ b/dev-python/wheel/wheel-0.24.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.python.org/pypi/wheel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""