summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wsaccel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wsaccel')
-rw-r--r--dev-python/wsaccel/Manifest1
-rw-r--r--dev-python/wsaccel/metadata.xml12
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.2.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/wsaccel/Manifest b/dev-python/wsaccel/Manifest
new file mode 100644
index 000000000000..433cb423ae0a
--- /dev/null
+++ b/dev-python/wsaccel/Manifest
@@ -0,0 +1 @@
+DIST wsaccel-0.6.2.tar.gz 35773 SHA256 425706acf0724d2f6bfa391ec37b4ef121d3432c956029de3cea4e101c218e0c SHA512 fbc59803cbb6b113a3e412390eb02f41a68513b9fda6e4408d5e2e3c976a3f62eacc6bf87adf9295a63238390cce00f4abe13daf397a28ce8f3ed3e3bff622ee WHIRLPOOL 2c66ff720fcaecaa8c7fe29d93bb8f32e620898b0ccf31d3dc3f4dbfe4b1623dde6484e3c347649cd4140ec51b52c9a8c0e81b0c24e6135481ebae7a26c09063
diff --git a/dev-python/wsaccel/metadata.xml b/dev-python/wsaccel/metadata.xml
new file mode 100644
index 000000000000..8db9521249a5
--- /dev/null
+++ b/dev-python/wsaccel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">wsaccel</remote-id>
+ <remote-id type="github">methane/wsaccel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wsaccel/wsaccel-0.6.2.ebuild b/dev-python/wsaccel/wsaccel-0.6.2.ebuild
new file mode 100644
index 000000000000..72890f83f2b9
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, AutobahnPython and tornado"
+HOMEPAGE="https://pypi.python.org/pypi/wsaccel https://github.com/methane/wsaccel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+#RDEPEND=""
+#DEPEND="
+# test? ( dev-python/nose )"
+
+_python_test() {
+ cd tests || die
+ nosetests || die
+}