summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 19:39:02 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 20:04:30 +0100
commitefcd7f0946f6f26cea349f36cc4a486f381b39ae (patch)
treeab97084184826dd539ba464030faf0650548b166 /dev-python/xmltodict
parentdev-python/reconfigure: Bump (diff)
downloadgentoo-efcd7f0946f6f26cea349f36cc4a486f381b39ae.tar.gz
gentoo-efcd7f0946f6f26cea349f36cc4a486f381b39ae.tar.bz2
gentoo-efcd7f0946f6f26cea349f36cc4a486f381b39ae.zip
dev-python/xmltodict: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/xmltodict')
-rw-r--r--dev-python/xmltodict/Manifest1
-rw-r--r--dev-python/xmltodict/xmltodict-0.10.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/xmltodict/Manifest b/dev-python/xmltodict/Manifest
index f747e3c28c00..65ec99c479fd 100644
--- a/dev-python/xmltodict/Manifest
+++ b/dev-python/xmltodict/Manifest
@@ -1,2 +1,3 @@
+DIST xmltodict-0.10.1.tar.gz 24620 SHA256 b2cab0184bbb8c3627fc54b03ed79ea2f4d5579fa041e3456ff8d3b3c09b0d5e SHA512 b2fdccf2a158256d8b2a78fdaf2c5527c6c25753da344864024fa8ef1d4e4b9a561d2802b10b668ea72af50dd41d05ca590dbf036a4b97c175b7788642ca3c63 WHIRLPOOL 4f239872ab411ec8c18c5184172e5cfa3a535ea3c86d92884e2993a57e10196925e32fd2139a76198d7cb739f0432cdf1d4fffc082b57c50946e5e4d2db21b1a
DIST xmltodict-0.9.1.tar.gz 37721 SHA256 ba676bec7a2a2e8be0565c26807db8661f1bfd49b5fd7b2d89731270137f49f3 SHA512 4dd3ef1424f74185d37e41c6860c37c63e4d11735bd5e111025429b66ae2bff8b07a30f245dc40c85dc3e657fdfd3e91d7074adc69fc0d4b7bde1bf16d6010ac WHIRLPOOL d4dd1e1af07778757f2de80bc606656ef1488589d50f8da7d68894b9c66e7a6b3f6bc7a5ad0c35aa93e661ec9fadae028261df59dd79b9b922c274eb29d27c02
DIST xmltodict-0.9.2.tar.gz 37875 SHA256 275d1e68c95cd7e3ee703ddc3ea7278e8281f761680d6bdd637bcd00a5c59901 SHA512 0d2bd2cce9b4484514cf16df92abdf26dfd17e222ea6a9285ca1216858bc8092bd328f39b8af851a1293e9d72f140775e12236a440004783a6bfd2321efec0c5 WHIRLPOOL 909460169cd3948dfc231040cc7f827436aafe0bd89b246e1cbf15699c84356e2947c704a555f62d4e378481b5acd5893a67bf31a9d97cb4b8f7a01fe378f76c
diff --git a/dev-python/xmltodict/xmltodict-0.10.1.ebuild b/dev-python/xmltodict/xmltodict-0.10.1.ebuild
new file mode 100644
index 000000000000..5450c5d635f4
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.10.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}