summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 18:20:01 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 22:06:06 +0100
commit2cebf9ee0d6fa2e7d3d56f7fbc276d67ca6fc605 (patch)
tree54f10b59eea35a79ca858e65af86ef856fcbf0cf /dev-python
parentdev-python/websocket-client: Version Bump (diff)
downloadgentoo-2cebf9ee0d6fa2e7d3d56f7fbc276d67ca6fc605.tar.gz
gentoo-2cebf9ee0d6fa2e7d3d56f7fbc276d67ca6fc605.tar.bz2
gentoo-2cebf9ee0d6fa2e7d3d56f7fbc276d67ca6fc605.zip
dev-python/terminado: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/terminado/Manifest1
-rw-r--r--dev-python/terminado/terminado-0.6.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/terminado/Manifest b/dev-python/terminado/Manifest
index 95ea497a5f17..e1142320a5da 100644
--- a/dev-python/terminado/Manifest
+++ b/dev-python/terminado/Manifest
@@ -1 +1,2 @@
DIST terminado-0.5.tar.gz 10491 SHA256 63e893eff1ba84f1ee7c4bfcca7676ba1de6394538bb9aa80cbbc8866cb875b6 SHA512 8c53e2c8fa837c171a8790744770f41d4fc8fe15fe8abd28af17317950c615e4c75c22ab896fd98984fd9c2bbbc7798e5ffe319827d84eb77889bca63660e421 WHIRLPOOL 0e603e49a754a4c5fa68b1df3416a6355357ab5af6801968385525bb2df2a558ffe73030f1789610b731638b57d9d5c1a5661c86de93984f8e2047bf205925b1
+DIST terminado-0.6.tar.gz 10334 SHA256 2c0ba1f624067dccaaead7d2247cfe029806355cef124dc2ccb53c83229f0126 SHA512 9b9521917d4000aa45e61a1b88705e715f11686890671607cca81d4518f1e17feefdc2ad3de64dd0e053a6849956efbbd838c7b98d570dcc98a936c0a4cfce9c WHIRLPOOL 832f7deea094856a0bf3fed3610561896a8906c4339dcc47197b85ee36ab47a385f6e180ebe65a9141ca946761ed6a94552fe9c21e4c792cac3a061b3403a5dc
diff --git a/dev-python/terminado/terminado-0.6.ebuild b/dev-python/terminado/terminado-0.6.ebuild
new file mode 100644
index 000000000000..4746ac57775e
--- /dev/null
+++ b/dev-python/terminado/terminado-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.python.org/pypi/terminado https://github.com/takluyver/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ >=www-servers/tornado-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbosity=3 || die
+}