summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-30 15:40:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-30 16:34:35 -0500
commit370ab6b26f1933192a4b1bd3c0b789fa34dfaa19 (patch)
tree46f1a53f041322726a5d70e3dbc2d6b63bf34e1c /dev-python
parentprofiles/arm64: block doc use flag on stevedore (diff)
downloadgentoo-370ab6b26f1933192a4b1bd3c0b789fa34dfaa19.tar.gz
gentoo-370ab6b26f1933192a4b1bd3c0b789fa34dfaa19.tar.bz2
gentoo-370ab6b26f1933192a4b1bd3c0b789fa34dfaa19.zip
dev-python/webob: 1.8.2 bump for rocky
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webob/Manifest1
-rw-r--r--dev-python/webob/webob-1.8.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/webob/Manifest b/dev-python/webob/Manifest
index 66b735491f04..95128f245ea0 100644
--- a/dev-python/webob/Manifest
+++ b/dev-python/webob/Manifest
@@ -1,2 +1,3 @@
DIST WebOb-1.7.3.tar.gz 216028 BLAKE2B 66af12ab34dc9a18555c6e480099a2c9b9f0ba8eb8f1e1066d501dea9ed2ff541c064bc40bfc74c284fef5f06281178d4d631b33f29c04d43da9c8e3bd138d0a SHA512 23a51f184754c525dc293b8b71855d40f52445c0df5434af7ec091219e0ea81be162623157b6ec67214cd151b25014bf86991246785816ebcb5a0d1eec9479a1
DIST WebOb-1.7.4.tar.gz 219331 BLAKE2B fe046905bf127dc8fedbf2b993e83b3614cd62ef614add939d54e241ecfc9a9ed77cfa5b961b436105c72cab36e885f94d604cd90909cc4ada9283c7a098a8ca SHA512 43685daf6dbba5daa99e4fabfb930495b8c2bc976e968d93af7681284cc127d7012f8423b2986dd7daa10cbf7b3803aec442c1ef88102e16cadf07efe6714d1a
+DIST WebOb-1.8.2.tar.gz 271737 BLAKE2B c6eef650e9b03c83d7c618d0187ef7fbd3432d043ab27501cf8c4d6dc3889f3b542c54bf35963d8a313d62246183373c30706bcf5fd00495808e21d3dc9e0482 SHA512 691a6cfbbff376e7b1f71adcaac4dbe8cc26cb4ddc396e2ab946ddf15b34c05c638113f48ee396d4edaf6ef77498ca8539d1c63de9f58894afb0e4b88bbf04ae
diff --git a/dev-python/webob/webob-1.8.2.ebuild b/dev-python/webob/webob-1.8.2.ebuild
new file mode 100644
index 000000000000..4d52d74f8fde
--- /dev/null
+++ b/dev-python/webob/webob-1.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="https://webob.org/ https://pypi.org/project/WebOb/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}