summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 11:43:46 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit3b4279817476c515f956eec1360ec49cd16a9d65 (patch)
tree89a8fe4c6e43631b9525a887de329245913c5381 /dev-python
parentdev-python/characteristic: Add python3.5 support (diff)
downloadgentoo-3b4279817476c515f956eec1360ec49cd16a9d65.tar.gz
gentoo-3b4279817476c515f956eec1360ec49cd16a9d65.tar.bz2
gentoo-3b4279817476c515f956eec1360ec49cd16a9d65.zip
dev-python/ndg-httpsclient: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0-r1.ebuild28
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild2
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0-r1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..c2341b1d3094
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
index 4e670396c195..b2a1f73ca755 100644
--- a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE=""
-RDEPEND="dev-python/pyopenssl[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"