summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 13:35:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 16:10:23 +0200
commit4825d7cef9cdcb79345ed8c97ab2b599dbe2ff16 (patch)
treed7d945f9f66d0a6547d4e1f225f0fbbdf25c61e3 /dev-python
parentdev-python/QtPy: Drop USE=pyside,pyqt5 (diff)
downloadgentoo-4825d7cef9cdcb79345ed8c97ab2b599dbe2ff16.tar.gz
gentoo-4825d7cef9cdcb79345ed8c97ab2b599dbe2ff16.tar.bz2
gentoo-4825d7cef9cdcb79345ed8c97ab2b599dbe2ff16.zip
dev-python/QtPy: Drop old
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/QtPy/QtPy-1.3.1.ebuild48
-rw-r--r--dev-python/QtPy/QtPy-1.4.0.ebuild48
-rw-r--r--dev-python/QtPy/metadata.xml2
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/QtPy/QtPy-1.3.1.ebuild b/dev-python/QtPy/QtPy-1.3.1.ebuild
deleted file mode 100644
index de40764e990..00000000000
--- a/dev-python/QtPy/QtPy-1.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstraction layer for PyQt5/PySide"
-HOMEPAGE="https://github.com/spyder-ide/qtpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="designer gui opengl +pyqt5 pyside svg testlib webkit"
-
-REQUIRED_USE="|| ( pyqt5 pyside ) webkit? ( pyqt5 )"
-
-RDEPEND="
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?,webkit?]
- gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
- testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
- )
- pyside? (
- dev-python/pyside[${PYTHON_USEDEP},designer?,opengl?,svg?]
- gui? ( dev-python/pyside[${PYTHON_USEDEP},X] )
- testlib? ( dev-python/pyside[${PYTHON_USEDEP},X] )
- )
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
- default
-
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.Qt import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- if ! use pyside; then
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- fi
-}
diff --git a/dev-python/QtPy/QtPy-1.4.0.ebuild b/dev-python/QtPy/QtPy-1.4.0.ebuild
deleted file mode 100644
index 67ff013c69f..00000000000
--- a/dev-python/QtPy/QtPy-1.4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstraction layer for PyQt5/PySide"
-HOMEPAGE="https://github.com/spyder-ide/qtpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="designer gui opengl +pyqt5 pyside svg testlib webkit webengine"
-
-REQUIRED_USE="|| ( pyqt5 pyside ) webkit? ( pyqt5 )"
-
-RDEPEND="
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?,webkit?,webengine?]
- gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
- testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
- )
- pyside? (
- dev-python/pyside[${PYTHON_USEDEP},designer?,opengl?,svg?]
- gui? ( dev-python/pyside[${PYTHON_USEDEP},X] )
- testlib? ( dev-python/pyside[${PYTHON_USEDEP},X] )
- )
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
- default
-
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.Qt import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- if ! use pyside; then
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- fi
-}
diff --git a/dev-python/QtPy/metadata.xml b/dev-python/QtPy/metadata.xml
index f7b2b130bc4..e1b8d6e3aa7 100644
--- a/dev-python/QtPy/metadata.xml
+++ b/dev-python/QtPy/metadata.xml
@@ -18,8 +18,6 @@
<use>
<flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
<flag name="gui">Build bindings for the QtGui module</flag>
- <flag name="pyqt5">Enable the <pkg>dev-python/PyQt5</pkg> backend</flag>
- <flag name="pyside">Enable the <pkg>dev-python/pyside</pkg> backend</flag>
<flag name="svg">Build bindings for the QtSvg module</flag>
<flag name="testlib">Build bindings for the QtTest module</flag>
<flag name="webengine">Build bindings for the QtWebEngine module</flag>