summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-28 20:08:10 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-28 20:08:10 +0700
commit657dc0c757577f095c815ce6fa4210b11794e935 (patch)
tree7560fef9bcfd84d1c726b4106724cfd2bc0e705d /dev-python
parentdev-python/wcwidth: python3_6 added (diff)
downloadgentoo-657dc0c757577f095c815ce6fa4210b11794e935.tar.gz
gentoo-657dc0c757577f095c815ce6fa4210b11794e935.tar.bz2
gentoo-657dc0c757577f095c815ce6fa4210b11794e935.zip
dev-python/pyte: python3_6 added
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyte/pyte-0.5.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.5.2-r2.ebuild b/dev-python/pyte/pyte-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..895b969586ff
--- /dev/null
+++ b/dev-python/pyte/pyte-0.5.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: e4e2b831b5f1d06aaed61962ec461f64fb4e833c $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.python.org/pypi/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}