summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:17:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:59 -0500
commit89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7 (patch)
tree0395af720a0632476bffe6f152a8abbd81f84c27 /dev-python
parentdev-python/python-barbicanclient: add py37 support (diff)
downloadgentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.tar.gz
gentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.tar.bz2
gentoo-89a0c1e6967f3fd6ef5a736bd06e84d6316ac6f7.zip
dev-python/castellan: 1.2.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/castellan/Manifest1
-rw-r--r--dev-python/castellan/castellan-1.2.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
index 1db59b488156..2df9e1571d6b 100644
--- a/dev-python/castellan/Manifest
+++ b/dev-python/castellan/Manifest
@@ -1,2 +1,3 @@
DIST castellan-0.12.2.tar.gz 50938 BLAKE2B 03cec0cd85042c482432bef7a0115413a9ea03aab05555dc1d4a65b5cb9893b57e2164a5174fb984c8ffcd190b27f9c26552dc242f9d79e3d60dce5a4a27479e SHA512 11ed1eb7fa1e5721f26afe23299ac7b0d13b4570b1f0670f4b13ac05149bdb9b9daa85cd1b29374f7d67eaa22957088b2f42313e23d8c0adf4edef108f7b44d9
DIST castellan-0.17.0.tar.gz 61193 BLAKE2B 91f9a4d6b495bd4bb8f1f00a9b2435a892a7ea2f6f64d36423aee3c87250deda73cdcb2070e12cb1c38c5ca716c4365d489990e7b07f35fa7e6e597eda442af7 SHA512 21b702cf73cf62456d677d01706f23e9d64c726d06d867d61559b0b221e016f519c067c1f10e540fb25bb73841ef633b7b4a602ed13ae64456aaa4843ee19c53
+DIST castellan-1.2.2.tar.gz 67085 BLAKE2B 5a6af5fd91e1371ed9024bf09f31bc5b9e7d55455a61c6c23f62fe84d80f717e83c96f2c72375c37537fe4fb7484b7a16e668f6e37ffa14bfa04f6e1fb69eaeb SHA512 3777180ecc2a2a26c917d89dff28d2ff9e20e1de86249b0e5cda63027394dd8b5a763314135bebba3d2b6194825068c9a7c1c32a4a1e3185caaed74a105aa032
diff --git a/dev-python/castellan/castellan-1.2.2.ebuild b/dev-python/castellan/castellan-1.2.2.ebuild
new file mode 100644
index 000000000000..ed896641438c
--- /dev/null
+++ b/dev-python/castellan/castellan-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.org/project/castellan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.5.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+"