summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 13:00:02 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 15:20:41 +0200
commit9728700f8da5d552dd1376dbb74d6b5b728f460e (patch)
treeb1f169660bf0048390ce2ad3f986a2216ff8f0f9 /dev-python
parentapp-vim/info: Clean up old. (diff)
downloadgentoo-9728700f8da5d552dd1376dbb74d6b5b728f460e.tar.gz
gentoo-9728700f8da5d552dd1376dbb74d6b5b728f460e.tar.bz2
gentoo-9728700f8da5d552dd1376dbb74d6b5b728f460e.zip
dev-python/datashape: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/datashape/Manifest1
-rw-r--r--dev-python/datashape/datashape-0.5.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/datashape/Manifest b/dev-python/datashape/Manifest
index f6e1e9da2f01..9b04a8fd7c4c 100644
--- a/dev-python/datashape/Manifest
+++ b/dev-python/datashape/Manifest
@@ -5,3 +5,4 @@ DIST datashape-0.4.6.tar.gz 94083 SHA256 872929d992929ee23ea939984d43d726458ddaa
DIST datashape-0.4.7.tar.gz 92581 SHA256 1028378bb56e8546a07cd3ad09247672516468ab395aa87646c4791488ba1794 SHA512 c5e4f9ef36456d6673c7cb50297d36cf0080cb08d9da81ff044853cc9bb52d659bc6c0beeb6d95d47ff6924aab50b67ac28eb906e7049624fe5d923a304c0ad0 WHIRLPOOL 7bfc2491a8598cc5a3574ced486d6b19308f45155002a0703e4d57fdc23f2ad270cde500ed65af9520a69c6538bf3622f733a19d56509bd65e5bb981d64118ec
DIST datashape-0.5.0.tar.gz 97748 SHA256 d0b7eafd84fbc75941e274b1bd9c26327ee90f3a1872e7e9b72693f49bee4f0f SHA512 670049fdc6e829805bdf4bf50ffb037bfa2b48fcc3e8772ac82a030fbb3d9c2dd084b6d2ed79cbe08a6e8d074b9fc54a7836f530f5fb45bf96df8b2fb9a8eaa1 WHIRLPOOL bc30f093889951ce47e9eacbad7dbfc5dd1257c9a6cc2a7692660b28b123fc40912f68dfb52bc387fc03043dd35cff5b7d51693ee69f153539653536738c6590
DIST datashape-0.5.1.tar.gz 98160 SHA256 bbb1dbcbfa285c4ecf0d2ee14b7017b3ea357935537c736bc51eca07d2bd4f47 SHA512 cb882b76f2b0a0f0321fcb41fe59dd5a1465f07bc58dc817400cd2d17d8a2b34a2ca944c24629616684ea6c6cf3f19365f539a2b58baf83f8ecebe6896a8beb8 WHIRLPOOL 7b78d1a0fbc1233666915715448d4552b948b82198773b5d13f43169f59513e43ceca2ccb9d625d64d83f58f122272f56b952cb3d0156c0f8b7512427f702490
+DIST datashape-0.5.2.tar.gz 99032 SHA256 7f964969944bfcd61904c4f40210429723d0db91e57d543660b38bbe1da4806b SHA512 731d65d0dd82310d0101386bb0df8169f940d8e6e3a749fd2b40996ee8dddf046ae83bdee0417e0bb156e6d8c00a03f53839a1b5eae4c4867eedfff338df99e6 WHIRLPOOL f876bfe31446b0a573b8293a068ef45fc53dc1845aa10bf86ab23ffff9ea2fc6a481f5c11288c5b971fc626b93dfd41baf22f54423b13d441d167d60ab598182
diff --git a/dev-python/datashape/datashape-0.5.2.ebuild b/dev-python/datashape/datashape-0.5.2.ebuild
new file mode 100644
index 000000000000..602a6f46c051
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}