summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 13:08:51 -0500
committerMichał Górny <mgorny@gentoo.org>2018-04-29 12:29:23 +0200
commitce03630f05278e2f0d559cd7136cc0287ed0d835 (patch)
tree45304ba6288c3d4350edde035b7e2e009e526b79 /dev-python
parentdev-python/autopep8: git-2->git-r3 (diff)
downloadgentoo-ce03630f05278e2f0d559cd7136cc0287ed0d835.tar.gz
gentoo-ce03630f05278e2f0d559cd7136cc0287ed0d835.tar.bz2
gentoo-ce03630f05278e2f0d559cd7136cc0287ed0d835.zip
dev-python/flask: git-2->git-r3, unify ebuilds
dev-python/flask-9999 does not install properly due to flask/json not being found, issue exists without my changes as well. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask/flask-0.12.2.ebuild25
-rw-r--r--dev-python/flask/flask-9999.ebuild38
2 files changed, 36 insertions, 27 deletions
diff --git a/dev-python/flask/flask-0.12.2.ebuild b/dev-python/flask/flask-0.12.2.ebuild
index 498dd328b2fe..a6175a6ac4c9 100644
--- a/dev-python/flask/flask-0.12.2.ebuild
+++ b/dev-python/flask/flask-0.12.2.ebuild
@@ -7,30 +7,33 @@ PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
inherit distutils-r1
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
HOMEPAGE="https://github.com/pallets/flask/"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/click-2[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
+ >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 0b68b4717e59..3329ccaa5a94 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,43 +1,49 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+EAPI=6
-inherit distutils-r1 git-2
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+inherit distutils-r1
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="https://pypi.org/project/Flask/"
MY_PN="Flask"
MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://pypi.org/project/Flask/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="examples test"
+IUSE="doc examples test"
RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
>=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-#if LIVE
-SRC_URI=
-KEYWORDS=
-#endif
+python_compile_all() {
+ use doc && emake -C docs html
+}
python_test() {
py.test tests || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- use examples && local EXAMPLES=( examples/. )
+ use examples && dodoc -r examples
+ use doc && HTML_DOCS=( docs/_build/html/. )
+
distutils-r1_python_install_all
}