summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-19 19:23:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-20 22:35:23 +0100
commitceab94b042fd72f1daa359b5790ea08ac6d8671c (patch)
tree6f0ec64a53a83d8164f9ddfa1b66704a0c674998 /dev-python
parentdev-python/cssutils: add support for Python3.7, EAPI 7. (diff)
downloadgentoo-ceab94b042fd72f1daa359b5790ea08ac6d8671c.tar.gz
gentoo-ceab94b042fd72f1daa359b5790ea08ac6d8671c.tar.bz2
gentoo-ceab94b042fd72f1daa359b5790ea08ac6d8671c.zip
dev-python/cssutils: remove 1.0.2 (r0).
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cssutils/cssutils-1.0.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2.ebuild b/dev-python/cssutils/cssutils-1.0.2.ebuild
deleted file mode 100644
index bcb2600b3e7f..000000000000
--- a/dev-python/cssutils/cssutils-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable test failing with dev-python/pyxml installed.
- if has_version dev-python/pyxml; then
- sed -e "s/test_linecol/_&/" \
- -i src/cssutils/tests/test_errorhandler.py \
- || die
- fi
-
- # requires old pbr, does it really?
- sed \
- -e '/tests_require/d' \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
- # esetup.py test
- # exclude tests that connect to the network
- set -- nosetests \
- -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
- echo "$@"
- "$@" || die "Testing failed with ${EPYTHON}"
-}