summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-11 23:24:47 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-11 23:48:54 -0500
commitebc72a2ebd0831e8fc99f736074b0b178fb8a722 (patch)
tree505950987195bbc1cf6637616046b7cf782f7797 /dev-python
parentdev-util/bpftrace: remove check for EBPF_JIT since it can't be set (diff)
downloadgentoo-ebc72a2ebd0831e8fc99f736074b0b178fb8a722.tar.gz
gentoo-ebc72a2ebd0831e8fc99f736074b0b178fb8a722.tar.bz2
gentoo-ebc72a2ebd0831e8fc99f736074b0b178fb8a722.zip
dev-python/xmltodict: version bump to 0.12.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xmltodict/Manifest1
-rw-r--r--dev-python/xmltodict/xmltodict-0.12.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xmltodict/Manifest b/dev-python/xmltodict/Manifest
index c4f9109cd4f0..b498770a0488 100644
--- a/dev-python/xmltodict/Manifest
+++ b/dev-python/xmltodict/Manifest
@@ -1 +1,2 @@
DIST xmltodict-0.11.0.tar.gz 26589 BLAKE2B 29498ac9c2f80828aa24d6cc4866aa6846fe10eb411a3e3617d85989c88628cc7c87ab80adb9ded492545fa2b4796a14b540479da75bfe464d1dfd811bbe1dc9 SHA512 d42ef146a40f386a5389958f890605c560ce9db2da4447099b8725edc1998339b77ea732576fc7e77fbe5a755a2dc3239dfae4a82fc6593c5f977145ab445295
+DIST xmltodict-0.12.0.tar.gz 18481 BLAKE2B f7b7b71a6eaacc833a54369be38aa988b5c27845b19001c1d13e955df1f3a26c04dd2a1b45f0c0e704c4df6f4d380abdda7189944cc45b001eeef55405c43299 SHA512 1ec3de3ebd05adbe032ca569a71048e72097c0f5fc864b63f168d661f72d13d0981e6e62bb9ca2ffe925a3b2f7c2fb90a44177427d4bdf68137842342a9cd2c8
diff --git a/dev-python/xmltodict/xmltodict-0.12.0.ebuild b/dev-python/xmltodict/xmltodict-0.12.0.ebuild
new file mode 100644
index 000000000000..12e48727d095
--- /dev/null
+++ b/dev-python/xmltodict/xmltodict-0.12.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Makes working with XML feel like you are working with JSON"
+HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.org/project/xmltodict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}