summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-02 10:23:10 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-02 10:23:10 -0500
commitf14a28b1c16c1c769f5954a2257371350f8c0462 (patch)
tree52920d52100a37dc2613cbdd9001ac6df30c36e4 /dev-python
parentdev-python/botocore: remove version 1.4.25 (diff)
downloadgentoo-f14a28b1c16c1c769f5954a2257371350f8c0462.tar.gz
gentoo-f14a28b1c16c1c769f5954a2257371350f8c0462.tar.bz2
gentoo-f14a28b1c16c1c769f5954a2257371350f8c0462.zip
dev-python/stormpath: add version 2.4.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.4.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 4411481cdb76..938b6066fb32 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,3 +1,4 @@
DIST stormpath-2.1.5.tar.gz 4339093 SHA256 cea6810c5caa666c3a73ea0bbf14826687318aea2a82c51d93886679b786b94b SHA512 d373d36bd6dc647fcedad99722c6ff53447b4b11090ffbbf2e72a206d27e66804d7e756d0588b80b11110700297beebb894b4d5301df97a836a4204622ea83af WHIRLPOOL 14a580f934afc74f7f15b4ac897474bb00ab199470d94c671b3f39c625d460aa601329a18cf23b206f12ab2b0f9f25d5903c14f507f614e38953da47bdfc7a92
DIST stormpath-2.1.6.tar.gz 4339678 SHA256 47649cf8edaf5ef48346f74558e62e0aaf28fb49bd7e3db99db9338739913d77 SHA512 2cc6ecd674ca6b5fcfbb6664f863cb4c6378748eb5ca2ceb5e0db3ac46c567a4b62a1bb595044b15c0294b5abe471c9ac675b93db49e5d2e146cd8954c8c7611 WHIRLPOOL c15085c2a1e5600ff93bc1e013439270c17472035a39fde52f31e21971b5508b4ff50a9a5f1472aa185282fefbfc9015a88eed0b5c641acf787abfaf9f72e06b
DIST stormpath-2.3.1.tar.gz 4346382 SHA256 cf7e2e0784d62a1992b7708232a4af6a444a10523cb9f9e2893530d6b4cee8d0 SHA512 1e6308e45f41ff2094740063e8b2fc4dcb197bfa1fe617c89f95326410191670621defa7f8158b8dcc07b0e7a79a831c81cc9df22334c29d9f832691315076a9 WHIRLPOOL 91c17a5ed72679ba46c2311f6fec6f6fdd25209959bd8e58960289aef259ad7f8ff9335b668aeec471463b91fa8f6f6acf37a8f65870f3ab3c41d8af52a10c70
+DIST stormpath-2.4.0.tar.gz 4345415 SHA256 4c3ee97bf630f0fb9237bccedfd4c41997a47599d76d319cfb84e95d7ec26db6 SHA512 4086c03b745427fa59d6b3739da38822781587d9d55bb0ea142dc70b9dd38ca98e8fdfbb167af6944440e7241ba63b2a2f58130b48789998fa3e263f11326a2b WHIRLPOOL 3425301a9c1858f5a602196be53e7a61961922786356f54f9fa3f033bb1b6460ad9ff32e4e0f2252e8b8220bd129fae5b8613771466f015e797b86d263391000
diff --git a/dev-python/stormpath/stormpath-2.4.0.ebuild b/dev-python/stormpath/stormpath-2.4.0.ebuild
new file mode 100644
index 000000000000..1885b70b2937
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ <=dev-python/oauthlib-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}