summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-20 21:22:04 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 15:40:24 +0200
commitf379e65bc7843c42faaf372b87a035932f78cb2b (patch)
tree13ba11d5fe7981cb0adf93df249db83241990078 /dev-python
parentdev-python/xlrd: Add python3.5 support (diff)
downloadgentoo-f379e65bc7843c42faaf372b87a035932f78cb2b.tar.gz
gentoo-f379e65bc7843c42faaf372b87a035932f78cb2b.tar.bz2
gentoo-f379e65bc7843c42faaf372b87a035932f78cb2b.zip
dev-python/ujson: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ujson/ujson-1.33.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/ujson/ujson-1.33.ebuild b/dev-python/ujson/ujson-1.33.ebuild
index 83591d2aea54..b0660cb35ba4 100644
--- a/dev-python/ujson/ujson-1.33.ebuild
+++ b/dev-python/ujson/ujson-1.33.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
# One test; FAIL: test_encodeToUTF8 (__main__.UltraJSONTests) under py2.5.
# Fix and repair and re-insert if it's REALLY needed
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -35,7 +35,7 @@ python_test() {
if [[ "${EPYTHON}" =~ 'python3' ]]; then
cd "${BUILD_DIR}"/lib || die
cp -a "${S}"/tests/ . || die
- 2to3 -w tests/tests.py
+ 2to3 -w tests/tests.py || die
"${PYTHON}" tests/tests.py || die
rm -rf tests/ || die
else