summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:10:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:57 -0500
commitf90723dc78d7ef0dd9609afd2ff84e6c4e31bf7d (patch)
treecc1b9966dcd97f21966055df918da13f5a18fe65 /dev-python
parentdev-python/paste: 3.0.7 bump (diff)
downloadgentoo-f90723dc78d7ef0dd9609afd2ff84e6c4e31bf7d.tar.gz
gentoo-f90723dc78d7ef0dd9609afd2ff84e6c4e31bf7d.tar.bz2
gentoo-f90723dc78d7ef0dd9609afd2ff84e6c4e31bf7d.zip
dev-python/debtcollector: 1.21.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-1.21.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 8f20bbb8a483..becdd8e42da7 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1,3 +1,4 @@
DIST debtcollector-1.11.0.tar.gz 26266 BLAKE2B e94c8754d730417638542229c0c47d798efeb2f55f203c51b337f516e356f930f476881bfba7e51824e0fcdda84a2aea4cfe238fa3251a35a9bf395942de7563 SHA512 9dcbfdaec5d16714d17eca2bfce7049c0a042b2370b1be5a4a0c0057dc28bf060ba570639581ceb5e5c27f2117f9001e4b2bb350899bdab0c0c7cdc3098a9bb2
DIST debtcollector-1.17.1.tar.gz 28805 BLAKE2B 25d965359ba815e182cddb2a8c82d7360e43ec549185380e759cb993dc44dae88bf1e6e21a67b6929862389f80450dc2f07eff7b2f7a5af58f1d8b64a2716255 SHA512 751ac56695369a36c4baa7fd60b3c0d2c027fb23f7b71cf4103acb70362af4455ebe50b73ca0ba4f946b318c38e67f3477ae937afd697d505a6f2455f932faa3
DIST debtcollector-1.19.0.tar.gz 26176 BLAKE2B be471b8ccb8cc3df3ade1af544f6326073f65cb1a6c64a8a864ee437692508fe21d7a117f47ab9f0c8cfb74502a7cf1c68e5e9dc26d8da3cd2ac0519c93be93b SHA512 f2bd1eeb9f402853e57ef6bd31d9961acc45617c50be36192b8761454869b3b9fc7709dbd14c36be469e6dbf3532f5d75a9fb863c7ea95c276f82d06f69a2164
+DIST debtcollector-1.21.0.tar.gz 28472 BLAKE2B a7c4a2d41ff6df1df1bfc2b775d888c1f9839ddb76bc80ff6b9bb9d1fb8e14eb225006021a0889d2a49c317c48f65cec024ff1d3c4e9c9bee1c0139a7cd1fc71 SHA512 a5a4f66a4d65134e84164de6953d4c6d5b2b9d36974055d26263b6d8505c4a131d693c371287ccd9c76220a9b59d6c3d1f0015db1d0f2bd8eafcb79c0bef0822
diff --git a/dev-python/debtcollector/debtcollector-1.21.0.ebuild b/dev-python/debtcollector/debtcollector-1.21.0.ebuild
new file mode 100644
index 000000000000..0e38212aceef
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-1.21.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || di
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}