summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-28 20:04:34 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-28 20:04:34 +0700
commitf930d8139d14d123572e6a96e81e7e8d1eea3772 (patch)
treef105a3d246bff7e4a722bb05377221757d940871 /dev-python
parentdev-python/blessings: python3_6 added (diff)
downloadgentoo-f930d8139d14d123572e6a96e81e7e8d1eea3772.tar.gz
gentoo-f930d8139d14d123572e6a96e81e7e8d1eea3772.tar.bz2
gentoo-f930d8139d14d123572e6a96e81e7e8d1eea3772.zip
dev-python/wcwidth: python3_6 added
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild b/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..88fbfdcbf965
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 5712ea6e8d0563cfbfecec3b894c63cd963647f4 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.python.org/pypi/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -rs --strict wcwidth/tests || die
+}