summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-04 12:54:36 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-04 12:54:42 +0100
commitfd304cb897dbfb7c2e3612e1c4931672b981eb9c (patch)
treefa120ea7623ccfdaf122f0123824ffeeffbe855d /dev-python
parentapp-office/scribus: Import latest changes into live ebuild (diff)
downloadgentoo-fd304cb897dbfb7c2e3612e1c4931672b981eb9c.tar.gz
gentoo-fd304cb897dbfb7c2e3612e1c4931672b981eb9c.tar.bz2
gentoo-fd304cb897dbfb7c2e3612e1c4931672b981eb9c.zip
dev-python/pandas: Import latest changes into live ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pandas/pandas-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/pandas/pandas-9999.ebuild b/dev-python/pandas/pandas-9999.ebuild
index 5ca059ca7e38..e0274323a5e5 100644
--- a/dev-python/pandas/pandas-9999.ebuild
+++ b/dev-python/pandas/pandas-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE="threads(+)"
@@ -63,7 +63,7 @@ OPTIONAL_DEPEND="
DEPEND="${MINIMAL_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.23[${PYTHON_USEDEP}]
doc? (
${VIRTUALX_DEPEND}
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
@@ -101,7 +101,14 @@ RDEPEND="
python_prepare_all() {
# Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/source/conf.py || die
+ sed \
+ -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -i doc/source/conf.py || die
+
+ # https://github.com/pydata/pandas/issues/11299
+ sed \
+ -e 's:testOdArray:disable:g' \
+ -i pandas/tests/io/json/test_ujson.py || die
distutils-r1_python_prepare_all
}
@@ -122,7 +129,7 @@ python_test() {
pushd "${BUILD_DIR}"/lib > /dev/null
"${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
PYTHONPATH=. MPLCONFIGDIR=. \
- virtx nosetests --verbosity=3 -A "${test_pandas}" pandas.io.tests.json.test_ujson.NumpyJSONTests
+ virtx nosetests --verbosity=3 -A "${test_pandas}" pandas
popd > /dev/null
}