summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-26 15:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-27 21:00:20 +0200
commit3af4117d918c855770200a2940b144809b14aa4c (patch)
tree55ee38d5677f7f9d9a5e563ab78361fb008659bc /dev-qt/linguist
parentprofiles: Mask Qt 5.11.1 for testing (diff)
downloadgentoo-3af4117d918c855770200a2940b144809b14aa4c.tar.gz
gentoo-3af4117d918c855770200a2940b144809b14aa4c.tar.bz2
gentoo-3af4117d918c855770200a2940b144809b14aa4c.zip
dev-qt: Add Qt 5.11.1 (masked)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest1
-rw-r--r--dev-qt/linguist/linguist-5.11.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index 3b8a03038ab4..31e8fca30610 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1,4 +1,5 @@
DIST qt-everywhere-opensource-src-4.8.7.tar.gz 241075567 BLAKE2B 6e9b8870692c36e894dc401b65fa38961cf7d033cd712770c273fd45b3221720648087c53787eae7d455c417d64e09f716da48377837fb5f2b52b901d06b1cf3 SHA512 f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b37084796b9b71ad0c317e4e6fd00017c10ea5d67b1b2032551cde00548522218125
DIST qttools-everywhere-src-5.11.0-rc2.tar.xz 9683312 BLAKE2B bca18b76d3519e8c3f62c54fafce0438c2403d2f3d3f88992216b068dadfacec71997437867a62b2b48764ef48d5433b78bfad24b5c17713c764927ca7d4e3b1 SHA512 0892645bafe1ada37dd353f3d6b8b3d4bd945a974501cb58354681310acab074705c98e91b2c4142b57b975e7806c2c712172c56c33bdfa9597201fbd5f26bfd
+DIST qttools-everywhere-src-5.11.1.tar.xz 9720996 BLAKE2B 5c7ca72ea6933e13eb07bafbd594db1dbde820c060d18cd26e30421b359633641a12834b0e9f0a94fac6c9df3d0d1e699a1bcb2d4831515509593813b021ad0f SHA512 cf690c630db79b4cd86d5d608175fb2c5463a985d7cb8a592c0995db04593c2c2ddddb52a3dc21348462639efdd3f9c57d3897a8384708b912b42cf1ac2c7482
DIST qttools-opensource-src-5.9.4.tar.xz 9779504 BLAKE2B 993b80c7e960e3dc968cd3a85cb5b78414a70fd73f89d687b753ac6eb37acea6d2dbf25e07686706f47eb803ead5d046f707fe52285451e6605ad27119a0cb54 SHA512 9a24f6118206076e8f6af1a257ba752aa3042aad3a1d6caafa3b221d811854f9d973de137cfd9b141b23db18f9b5101df70419c5ff17c75613f2a6ddb23c61c3
DIST qttools-opensource-src-5.9.6.tar.xz 9575188 BLAKE2B 117f9ad299ccf0a3ec0afe0c654731325bd6f39219bc9b473b43f02508f0b653a1ea3c202b9ecda187e0c25f4d02d22cb57f66c8aa812635823250b8f52d35f9 SHA512 2e72e88a6691491ff24b791254f2bb1e98bfc22b01a3ae3d5b8312ca75d4dea983e7949a1d445d9fd9b18c86ba9236489ba59e5562c6db60ec43dbd452b6b8d8
diff --git a/dev-qt/linguist/linguist-5.11.1.ebuild b/dev-qt/linguist/linguist-5.11.1.ebuild
new file mode 100644
index 000000000000..38f06fe3f5d8
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit desktop gnome2-utils qt5-build
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ gnome2_icon_cache_update
+}