summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-11 12:08:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 09:30:35 +0200
commit78d7f867dc4fa787c5b5f44de86cd2cc043d3d45 (patch)
tree02f4ea207e9cad8f4321d7633a9f18bf7682fc5d /dev-qt/linguist
parentdev-qt/qt-docs: 5.12.5_p201908230013 version bump (diff)
downloadgentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.tar.gz
gentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.tar.bz2
gentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.zip
dev-qt: Add Qt 5.12.5
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest1
-rw-r--r--dev-qt/linguist/linguist-5.12.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index 7933a6dc0816..85fcd87ade33 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.12.3.tar.xz 9809196 BLAKE2B 8d0317dc70c1dc6fc7c125453d22bbaa7decd57f9ba0f7572cc1e27f9494ff3423b5be412bcbd2e841a1f9b7494dae9101b3ac9254c563c24f22492b3b6ec3c9 SHA512 d37c0e11a26a21aa60f29f3b17ddc9895385d848692956e4481e49003cbe9c227daf8fda1c40a2ab70ac8e7e56d3771c1b2964524589eb77ac1f2362c269162e
DIST qttools-everywhere-src-5.12.4.tar.xz 9810980 BLAKE2B 214a3910232b7b60047e8c750b2850e2ab2de134246adffd69b4c2320b2faa2744b27f86b9837b75f32c09321021f9aa03301320abff3c37803601a64799c973 SHA512 072d09315fc73ec610d2e0d9a1380e5539a79fa1d73104a801e0f8b9afe489b735fefcc46d7c9e519ee8c1b14975386260239be24183933281dead2fec00f466
+DIST qttools-everywhere-src-5.12.5.tar.xz 9759888 BLAKE2B a9d8477a8f27de405c390d0901754020bed457dfaf7419cb070c5bf4eee30f3bb0b39bd29d3c32f8f78e82ffa8bc10e58cea3eae389792227cd6f21f783624c2 SHA512 e88af049ad9261720bc44ff9030113179d9429eaf073bed45115decd520ecf5d3ca860983f012bac189310ce9f3826b1fcb484faadb4f6d0b16c67c0d998f34c
diff --git a/dev-qt/linguist/linguist-5.12.5.ebuild b/dev-qt/linguist/linguist-5.12.5.ebuild
new file mode 100644
index 000000000000..b09b8354b377
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.12.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}