summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-18 23:14:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-18 23:39:12 +0200
commit59f65abccf9c18ffca2223466dbcac028aba3ca1 (patch)
treea24a4de1b6e92057845509129b7d9d6aefb6f0bf /dev-qt/qdoc
parentkde-apps/kiten: Drop 18.08.2 (r0) (diff)
downloadgentoo-59f65abccf9c18ffca2223466dbcac028aba3ca1.tar.gz
gentoo-59f65abccf9c18ffca2223466dbcac028aba3ca1.tar.bz2
gentoo-59f65abccf9c18ffca2223466dbcac028aba3ca1.zip
dev-qt: Add Qt 5.11.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-qt/qdoc')
-rw-r--r--dev-qt/qdoc/Manifest1
-rw-r--r--dev-qt/qdoc/qdoc-5.11.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-qt/qdoc/Manifest b/dev-qt/qdoc/Manifest
index 81229ba140a9..1e0238acd32b 100644
--- a/dev-qt/qdoc/Manifest
+++ b/dev-qt/qdoc/Manifest
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.11.1.tar.xz 9720996 BLAKE2B 5c7ca72ea6933e13eb07bafbd594db1dbde820c060d18cd26e30421b359633641a12834b0e9f0a94fac6c9df3d0d1e699a1bcb2d4831515509593813b021ad0f SHA512 cf690c630db79b4cd86d5d608175fb2c5463a985d7cb8a592c0995db04593c2c2ddddb52a3dc21348462639efdd3f9c57d3897a8384708b912b42cf1ac2c7482
+DIST qttools-everywhere-src-5.11.2.tar.xz 9691816 BLAKE2B 6391d9ec8c12789568db152a7131109e504449b82c738304f1360430d40c465a2f2bd6a77bf80ec8139c2ba93b896b62f59b6698a6f234ac606b9d2d396de211 SHA512 a950a3c1d8e6e92ba200e6834d1f88b8b98b91e3ab2e238aa4d229248f19103e38a06f0a81304ebdae70b96a60c87fdea8caae0181d2114da3e20e9148d08be5
DIST qttools-opensource-src-5.9.6.tar.xz 9575188 BLAKE2B 117f9ad299ccf0a3ec0afe0c654731325bd6f39219bc9b473b43f02508f0b653a1ea3c202b9ecda187e0c25f4d02d22cb57f66c8aa812635823250b8f52d35f9 SHA512 2e72e88a6691491ff24b791254f2bb1e98bfc22b01a3ae3d5b8312ca75d4dea983e7949a1d445d9fd9b18c86ba9236489ba59e5562c6db60ec43dbd452b6b8d8
diff --git a/dev-qt/qdoc/qdoc-5.11.2.ebuild b/dev-qt/qdoc/qdoc-5.11.2.ebuild
new file mode 100644
index 000000000000..6e802bc94b9f
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.11.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ sys-devel/clang:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qdoc
+)
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ export LLVM_INSTALL_DIR="$(llvm-config --prefix)"
+ # this is normally loaded in qttools.pro, so skipped by using
+ # QT_TARGET_SUBDIRS causing build to fail
+ sed -e '1iload(qt_find_clang)\' -i src/qdoc/qdoc.pro || die
+
+ qt5-build_src_prepare
+}