summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-07-09 15:38:10 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-07-09 16:06:04 +0200
commit8bb57e32cac5ae97d4cb720ba0690b2bb34873e5 (patch)
treebc0620a43a8d2318992718c975fce00d1ec8d3d6 /dev-qt/qt-creator/qt-creator-9999.ebuild
parentdev-qt/qt-creator: version bump (diff)
downloadgentoo-8bb57e32cac5ae97d4cb720ba0690b2bb34873e5.tar.gz
gentoo-8bb57e32cac5ae97d4cb720ba0690b2bb34873e5.tar.bz2
gentoo-8bb57e32cac5ae97d4cb720ba0690b2bb34873e5.zip
dev-qt/qt-creator: update build requirements for 9999
http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=7812390b0bdb31aec113fef317e4e83c4f822872 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-qt/qt-creator/qt-creator-9999.ebuild')
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index d743d862728..0a6f46bb720 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -5,7 +5,7 @@
EAPI=6
PLOCALES="cs de fr ja pl ru sl uk zh_CN zh_TW"
-inherit eutils l10n qmake-utils virtualx
+inherit eutils l10n qmake-utils toolchain-funcs virtualx
DESCRIPTION="Lightweight IDE for C++/QML development centering around Qt"
HOMEPAGE="http://doc.qt.io/qtcreator/"
@@ -39,7 +39,7 @@ IUSE="doc systemd test webengine webkit ${QTC_PLUGINS[@]%:*}"
REQUIRED_USE="?? ( webengine webkit )"
# minimum Qt version required
-QT_PV="5.5.0:5"
+QT_PV="5.6.0:5"
RDEPEND="
=dev-libs/botan-1.10*[-bindist,threads]
@@ -60,9 +60,9 @@ RDEPEND="
>=dev-qt/qtxml-${QT_PV}
>=sys-devel/gdb-7.5[client,python]
clangcodemodel? ( >=sys-devel/clang-3.6.2:= )
- qbs? ( >=dev-util/qbs-1.5.1 )
+ qbs? ( >=dev-util/qbs-1.5.2 )
systemd? ( sys-apps/systemd:= )
- webengine? ( >=dev-qt/qtwebengine-5.6.0:5 )
+ webengine? ( >=dev-qt/qtwebengine-${QT_PV} )
webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
"
DEPEND="${RDEPEND}
@@ -71,8 +71,8 @@ DEPEND="${RDEPEND}
doc? ( >=dev-qt/qdoc-${QT_PV} )
test? ( >=dev-qt/qttest-${QT_PV} )
"
+# qt translations must be installed for qt-creator translations to work
for x in ${PLOCALES}; do
- # qt translations must be installed for qt-creator translations to work
RDEPEND+=" linguas_${x}? ( >=dev-qt/qttranslations-${QT_PV} )"
done
unset x
@@ -90,9 +90,12 @@ PDEPEND="
"
src_unpack() {
- if [[ $(gcc-major-version) -lt 4 ]] || [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]]; then
- eerror "GCC version 4.7 or later is required to build Qt Creator ${PV}"
- die "GCC >= 4.7 required"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -lt 4 ]] || \
+ [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 8 ]]; then
+ eerror "GCC version 4.8 or later is required to build Qt Creator ${PV}"
+ die "GCC >= 4.8 required"
+ fi
fi
if [[ ${PV} == *9999 ]]; then