summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-16 13:45:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 22:20:42 +0100
commitc501b6c8adce80fc35e846f4aebfc6e3007f07cc (patch)
tree9c9b3f927119ac6693df67fcc6e4f6dd4aebb4a0 /dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild
parentdev-qt/qtwayland: Fix crash when showing a window with hidden parent (diff)
downloadgentoo-c501b6c8adce80fc35e846f4aebfc6e3007f07cc.tar.gz
gentoo-c501b6c8adce80fc35e846f4aebfc6e3007f07cc.tar.bz2
gentoo-c501b6c8adce80fc35e846f4aebfc6e3007f07cc.zip
dev-qt/qtdeclarative: Handle reads of QQmlPropertyMap correctly
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild
new file mode 100644
index 000000000000..90abd95d64ff
--- /dev/null
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.13.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2009-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-any-r1 qt5-build
+
+DESCRIPTION="The QML and Quick modules for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="gles2 +jit localstorage +widgets"
+
+BDEPEND="${PYTHON_DEPS}"
+# qtgui[gles2=] is needed because of bug 504322
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2=]
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qttest-${PV}
+ localstorage? ( ~dev-qt/qtsql-${PV} )
+ widgets? ( ~dev-qt/qtwidgets-${PV}[gles2=] )
+"
+RDEPEND="${DEPEND}
+ !<dev-qt/qtquickcontrols-5.7:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-read-QQmlPropertyMap-correctly.patch" # QTBUG-79614
+)
+
+src_prepare() {
+ use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
+
+ qt_use_disable_mod localstorage sql \
+ src/imports/imports.pro
+
+ qt_use_disable_mod widgets widgets \
+ src/src.pro \
+ src/qmltest/qmltest.pro \
+ tests/auto/auto.pro \
+ tools/tools.pro \
+ tools/qmlscene/qmlscene.pro \
+ tools/qml/qml.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ -qml-debug
+ )
+ qt5-build_src_configure
+}