summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 22:28:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-29 22:29:41 +0200
commit02b274605559aec67880f0f8024ff1d5064dfa4e (patch)
treeb473d843147cc1ffd26ece419c514bcd553abf20 /dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild
parentdev-qt/qtdiag: Add dev-qt/qtxml to DEPEND (diff)
downloadgentoo-02b274605559aec67880f0f8024ff1d5064dfa4e.tar.gz
gentoo-02b274605559aec67880f0f8024ff1d5064dfa4e.tar.bz2
gentoo-02b274605559aec67880f0f8024ff1d5064dfa4e.zip
dev-qt: Drop Qt 5.15.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild
deleted file mode 100644
index 0ee13270106b..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.15.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2009-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-IUSE="gles2-only +jit localstorage vulkan +widgets"
-
-BDEPEND="${PYTHON_DEPS}"
-# qtgui[gles2-only=] is needed because of bug 504322
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}:5=[gles2-only=,vulkan=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.14.2-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
- "${FILESDIR}/${PN}-5.14.2-fix-subpixel-positioned-text.patch" # QTBUG-49646
-)
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- -qml-debug
- )
- qt5-build_src_configure
-}