summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 22:35:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 23:40:47 +0100
commita663ab344d4deebd60dc35994eb659579412754d (patch)
treea5bf169a05fe2b3452a93f75cc460c51a61b44c4 /dev-qt/qtdeclarative
parentdev-db/redis: drop to ~hppa (diff)
downloadgentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.gz
gentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.bz2
gentoo-a663ab344d4deebd60dc35994eb659579412754d.zip
dev-qt: Add Qt 5.15.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/Manifest1
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-qt/qtdeclarative/Manifest b/dev-qt/qtdeclarative/Manifest
index a84d768da2c..8a106668178 100644
--- a/dev-qt/qtdeclarative/Manifest
+++ b/dev-qt/qtdeclarative/Manifest
@@ -1 +1,2 @@
DIST qtdeclarative-everywhere-src-5.15.1.tar.xz 21558724 BLAKE2B 15da5471799e461e5f5983fb0d947cad9d635a1bb0760da0b709f273ba9a9846df442f424d2009e857d831695d14a92c9be941270a07dc0f33cc46382ba44e6f SHA512 193ec706b764330a2ae00614b13482b7586642f9cfd32458e8c975daa07ba25f0f9887de0918c4034f52f613b860677c09c46a3b7d07d4229446cfc0805bcccd
+DIST qtdeclarative-everywhere-src-5.15.2.tar.xz 21559880 BLAKE2B 07fa82a55f79c081cf3cb713e6b90274f2b2c420eba958042f58989502e2ae572294c4cd02eb73767e87d84c9173fb154e45370c043f6adfc7fb1a93377e2edc SHA512 a084e4ace0d6868668c95f1b62598a7dd0f455bfb0943ac8956802d7041436686f20c7ccdde7d6fd6c4b8173c936dd8600cf3b87bf8575f55514edfbb51111d3
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild
new file mode 100644
index 00000000000..0a1641a4419
--- /dev/null
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2009-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1 qt5-build
+
+DESCRIPTION="The QML and Quick modules for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="gles2-only +jit localstorage vulkan +widgets"
+
+BDEPEND="${PYTHON_DEPS}"
+# qtgui[gles2-only=] is needed because of bug 504322
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}:5=[gles2-only=,vulkan=]
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qttest-${PV}
+ localstorage? ( ~dev-qt/qtsql-${PV} )
+ widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.14.2-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
+)
+
+src_prepare() {
+ use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
+
+ qt_use_disable_mod localstorage sql \
+ src/imports/imports.pro
+
+ qt_use_disable_mod widgets widgets \
+ src/src.pro \
+ src/qmltest/qmltest.pro \
+ tests/auto/auto.pro \
+ tools/tools.pro \
+ tools/qmlscene/qmlscene.pro \
+ tools/qml/qml.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ -qml-debug
+ )
+ qt5-build_src_configure
+}