summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-22 00:24:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-22 00:24:09 +0200
commitabd061d3980e30b57955e50b41f8c639deca5295 (patch)
tree032292f31c063f0c596f4127190f1f635bf0190d /dev-qt/qtdeclarative
parentdev-qt/qtmultimedia: Drop 5.14.2 (r0) (diff)
downloadgentoo-abd061d3980e30b57955e50b41f8c639deca5295.tar.gz
gentoo-abd061d3980e30b57955e50b41f8c639deca5295.tar.bz2
gentoo-abd061d3980e30b57955e50b41f8c639deca5295.zip
dev-qt/qtdeclarative: Drop 5.14.2-r2
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.14.2-r2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r2.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r2.ebuild
deleted file mode 100644
index 24d7551a2fd..00000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2009-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
-fi
-
-IUSE="gles2-only +jit localstorage vulkan +widgets"
-
-BDEPEND="${PYTHON_DEPS}"
-# qtgui[gles2-only=] is needed because of bug 504322
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2-only=,vulkan=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
- "${FILESDIR}/${P}-fix-subpixel-positioned-text.patch" # QTBUG-49646
-)
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- -qml-debug
- )
- qt5-build_src_configure
-}