summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-30 22:06:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-30 22:46:00 +0200
commitbc400dc11d5dae40db820619210e49adff1f4306 (patch)
tree4016548f3cf8d7a762fe6ea81051ccb9102298f9 /dev-qt/qtdeclarative
parentdev-util/clair: remove old (diff)
downloadgentoo-bc400dc11d5dae40db820619210e49adff1f4306.tar.gz
gentoo-bc400dc11d5dae40db820619210e49adff1f4306.tar.bz2
gentoo-bc400dc11d5dae40db820619210e49adff1f4306.zip
dev-qt: Drop Qt 5.14.1 and vulnerable dev-qt/qtgui
Bug: https://bugs.gentoo.org/719732 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/Manifest1
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.14.1-r2.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-qt/qtdeclarative/Manifest b/dev-qt/qtdeclarative/Manifest
index 6ab991ed5db..9b377618e3a 100644
--- a/dev-qt/qtdeclarative/Manifest
+++ b/dev-qt/qtdeclarative/Manifest
@@ -1,3 +1,2 @@
-DIST qtdeclarative-everywhere-src-5.14.1.tar.xz 21299728 BLAKE2B dfa0dfc95956f9c9eeb6b790e0221cf745b0cefd89fc070caa741b9cdc644acd990128affbcef6ac585758a02f94b1693ccca77d9de080f04f4d1b6d2304537f SHA512 70094d24a977a5ae4a3a11ee31e49234592faca1ec8195560977e7834778d1b1fdc2a30e555dc6c43c98cef2a39d5c1bf6351093c0f46b9b22b4127f3bebef58
DIST qtdeclarative-everywhere-src-5.14.2.tar.xz 21305980 BLAKE2B 0ccbae8ddc46f4891af6732a4b3cf874c523c7ded5a06f78c7c5cd290fef8e32ad6efe5dcffe947024144128ab2f1108594e4a30da9ca79e1ce3008c73ca2a25 SHA512 48d3a547237514a8bdc2a4c0b3f97732abceacece0e0899d2f33787293eb99f54c28efce35a34b8c46dcd4d78ebbc88bfc820bc68496076eacace40aaceee004
DIST qtdeclarative-everywhere-src-5.15.0.tar.xz 21493268 BLAKE2B c6b8365caa3e0eef3023d727adf086c16bafc171bcfa839a4dc83132b5c9a76c9a849b387f3815c1a9b12db5824ccc628cad22efd0ce0cb70059971cadfbb00b SHA512 0ec3403286efea6d6ac975ea6bd4464ea656c031f5f27b852235fd69d316a627ac3ff2ea2c3cca0a5375ca278f592df3ecade4e98aa15ec92816a16927f56e5e
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.14.1-r2.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.14.1-r2.ebuild
deleted file mode 100644
index 8aff110ecb6..00000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.14.1-r2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2009-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 x86"
-fi
-
-IUSE="gles2-only +jit localstorage vulkan +widgets"
-
-BDEPEND="${PYTHON_DEPS}"
-# qtgui[gles2-only=] is needed because of bug 504322
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2-only=,vulkan=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- -qml-debug
- )
- qt5-build_src_configure
-}