summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 11:18:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 16:32:27 +0200
commitaeb61e1abdbb629279cb188180567a3fb957d9e5 (patch)
tree1425b69473c31cd902abba3a496763dd2a325396 /dev-qt/qtlocation
parentqt5-build.eclass: Drop pre-Qt 5.14 quirks (diff)
downloadgentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.gz
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.bz2
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.zip
dev-qt: Add Qt 5.15.0 release
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index e2396666d14b..b0414cddb03b 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,3 @@
DIST qtlocation-everywhere-src-5.14.1.tar.xz 6119236 BLAKE2B 8ea66354f17e67d02c3e0a2a6369b55af006f6aa3f7d8b3c0c914df7d01db852a63d3e6a24f11516aea6667dbc9888a361fe9a030b903720f77456ffdaa96710 SHA512 5ccba22c27beb0bbde4b84e510e322445d98f99d87046d463bd054d0a09f0b24af978cf372006aa2cfca0a0ca0fcbb067525a6dc103d2d89592afec0600efcd8
DIST qtlocation-everywhere-src-5.14.2.tar.xz 6120852 BLAKE2B 0224cd6eecc182ddb960c6f3814d2d913a2776e879bb2e87a6c11f18840e275a770977df89c6bfa1aeb174502713969b5d8c02f9c46670671034f6879a41150f SHA512 ca11e118a9061f69ac0181db14b1bf92309c03615802092f7cf404c882108efa3acae9bb73ee3870ea68cd7d7d11863445fc72dcf52099d6be77e0986b7f012c
+DIST qtlocation-everywhere-src-5.15.0.tar.xz 6542152 BLAKE2B 11f218fdd4da4be7a1a7e5eff28f71144844ac6d2a70d8efafac4b5dc9fe3a32496bffeaa4446b3412de266feac72bc54b33e26e6c3286c0329ad882dadfaeee SHA512 36efb5a9a0eaaa6f2997c4d7a18307c69a80ae4caf901ab1d0efcc6cd6202dda6a10c8dac01baee44e84c14b8ab23204db1085445e1f3b42e9a0a21549eb624e
diff --git a/dev-qt/qtlocation/qtlocation-5.15.0.ebuild b/dev-qt/qtlocation/qtlocation-5.15.0.ebuild
new file mode 100644
index 000000000000..0772e510f28e
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}