summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-22 10:40:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-22 21:08:42 +0100
commit014ae7e4478dbcd1e9694098c5c37bc915f21297 (patch)
tree5be0e62379db3aa1965a4269366876447857b904 /dev-qt/qtsql
parentdev-qt/qtgui: Drop 5.9.4 (r0) (diff)
downloadgentoo-014ae7e4478dbcd1e9694098c5c37bc915f21297.tar.gz
gentoo-014ae7e4478dbcd1e9694098c5c37bc915f21297.tar.bz2
gentoo-014ae7e4478dbcd1e9694098c5c37bc915f21297.zip
dev-qt/qtsql: Extend the MariaDB define check
See also: https://mail.kde.org/pipermail/distributions/2018-February/000265.html See also: https://codereview.qt-project.org/#/c/206850/ Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtsql')
-rw-r--r--dev-qt/qtsql/files/qtsql-5.9.4-mariadb-10.2.patch35
-rw-r--r--dev-qt/qtsql/qtsql-5.9.4-r1.ebuild62
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-qt/qtsql/files/qtsql-5.9.4-mariadb-10.2.patch b/dev-qt/qtsql/files/qtsql-5.9.4-mariadb-10.2.patch
new file mode 100644
index 000000000000..bfd0c903bc35
--- /dev/null
+++ b/dev-qt/qtsql/files/qtsql-5.9.4-mariadb-10.2.patch
@@ -0,0 +1,35 @@
+From 64588c9bae92ef79f9ca5e87653ffb0962691d0d Mon Sep 17 00:00:00 2001
+From: Andy Shaw <andy.shaw@qt.io>
+Date: Wed, 27 Sep 2017 09:23:10 +0200
+Subject: [PATCH] Extend the MariaDB define check to cover the later versions
+ too
+
+Change-Id: Ide89b4e07feb116bf152cbf3f5630d313e8ba0f1
+---
+ src/plugins/sqldrivers/mysql/qsql_mysql.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
+index 6e428fb..b2d3e85 100644
+--- a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
++++ b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
+@@ -1159,14 +1159,14 @@ static void qLibraryInit()
+ # endif // MYSQL_VERSION_ID
+ #endif // Q_NO_MYSQL_EMBEDDED
+
+-#ifdef MARIADB_BASE_VERSION
++#if defined(MARIADB_BASE_VERSION) || defined(MARIADB_VERSION_ID)
+ qAddPostRoutine(mysql_server_end);
+ #endif
+ }
+
+ static void qLibraryEnd()
+ {
+-#if !defined(MARIADB_BASE_VERSION)
++#if !defined(MARIADB_BASE_VERSION) && !defined(MARIADB_VERSION_ID)
+ # if !defined(Q_NO_MYSQL_EMBEDDED)
+ # if MYSQL_VERSION_ID > 40000
+ # if (MYSQL_VERSION_ID >= 40110 && MYSQL_VERSION_ID < 50000) || MYSQL_VERSION_ID >= 50003
+--
+2.7.4
+
diff --git a/dev-qt/qtsql/qtsql-5.9.4-r1.ebuild b/dev-qt/qtsql/qtsql-5.9.4-r1.ebuild
new file mode 100644
index 000000000000..5d33391afb6c
--- /dev/null
+++ b/dev-qt/qtsql/qtsql-5.9.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="SQL abstraction library for the Qt5 tooolkit"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="freetds mysql oci8 odbc postgres +sqlite"
+
+REQUIRED_USE="
+ || ( freetds mysql oci8 odbc postgres sqlite )
+"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/libmysqlclient:= )
+ oci8? ( dev-db/oracle-instantclient-basic )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( >=dev-db/sqlite-3.8.10.2:3 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-mariadb-10.2.patch"
+ # See also: https://codereview.qt-project.org/#/c/206850/
+)
+
+QT5_TARGET_SUBDIRS=(
+ src/sql
+ src/plugins/sqldrivers
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :sql
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin)
+ $(qt_use oci8 sql-oci plugin)
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use postgres sql-psql plugin)
+ $(qt_use sqlite sql-sqlite plugin)
+ $(usex sqlite -system-sqlite '')
+ )
+
+ use mysql && myconf+=("-I${EPREFIX}/usr/include/mysql" "-L${EPREFIX}/usr/$(get_libdir)/mysql")
+ use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
+ use odbc && myconf+=("-I${EPREFIX}/usr/include/iodbc")
+ use postgres && myconf+=("-I${EPREFIX}/usr/include/postgresql/pgsql")
+
+ qt5-build_src_configure
+}