summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-28 20:07:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-01 10:24:37 +0100
commit1b4c9f2dbdb4fb32ab0250f0f5904a6985881059 (patch)
treebf72c58aa1c524fd65380ffa26b406148449b0ec /dev-qt/qtwayland
parentqt5-build.eclass: Relocate QT5_DOCDIR to /usr/share/qt5-doc (diff)
downloadgentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.tar.gz
gentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.tar.bz2
gentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.zip
dev-qt: Add Qt 5.12.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.12.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index b579cfdc1d05..35adaa1ae50f 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
DIST qtwayland-everywhere-src-5.11.3.tar.xz 391124 BLAKE2B 2bc90c7a6f6769bcae7e52072d71f38ad984cc931767613e7972373131c9d58c145e9882c29163190257f07a205bdda63f78833859d2be6d6478126c301b70a1 SHA512 e442a13c61a508d6021fb15a0917b7861faf139fb7dca41ac1a3967f4b8dc82da5095029e4c6120464bd36ecf559547fe2f42935d9980f19298f5875cfb5e62e
+DIST qtwayland-everywhere-src-5.12.1.tar.xz 430032 BLAKE2B 38d5119c5b7a02a0d1ead1bebe703b7c82651c660651ed45304657d83a70fba69fd741308ec72b99c4ceb22cefa88f0faae3a442fa9bcfcd8d128e6d049b7d15 SHA512 8f7dc79c2ac2cb91044ce2633d76b0dbcb586b48da5233d8d8d40056b6df448aca1f3b18e91156f050a87d4c6c54494c4ba3ebe573fa609dc1772c5427e79f43
diff --git a/dev-qt/qtwayland/qtwayland-5.12.1.ebuild b/dev-qt/qtwayland/qtwayland-5.12.1.ebuild
new file mode 100644
index 000000000000..dcdeeaa61c32
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.12.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ src/plugins/shellintegration/wl-shell/wl-shell.pro \
+ src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
+ src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
+ src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}