summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-11 01:20:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 14:03:14 +0100
commit608616191dce3dca8e059a86bd960c2ab0e44c39 (patch)
tree877828aaee7d7a7223ac76abdabe8c52a09fabf6 /dev-qt/qtxml
parentdev-qt/qtbluetooth: Fix build with GCC-11 (diff)
downloadgentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.tar.gz
gentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.tar.bz2
gentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.zip
dev-qt: Fix build for QT5_MODULE=qtbase w/ GCC-11
Closes: https://bugs.gentoo.org/752012 Closes: https://bugs.gentoo.org/764038 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtxml')
-rw-r--r--dev-qt/qtxml/Manifest1
-rw-r--r--dev-qt/qtxml/qtxml-5.15.2.ebuild4
2 files changed, 5 insertions, 0 deletions
diff --git a/dev-qt/qtxml/Manifest b/dev-qt/qtxml/Manifest
index 8d47df5d648d..c298c0aa243b 100644
--- a/dev-qt/qtxml/Manifest
+++ b/dev-qt/qtxml/Manifest
@@ -1 +1,2 @@
+DIST qtbase-5.15.2-gcc11.patch.xz 1208 BLAKE2B a2e5764b723adda991eca5b84cf8e15437a4832febd12e3c93cdc394931af666e17c01e229e9be7e0efc446a955cc26388c0f93cadfcabd93cc6b6f03bb41eb0 SHA512 da3a41ea5d9573a029946d26b26d51d6dce9c8b91db6d78ca71d8343d3ceb5010d21750dcb45abb663e227b5f068985ff4ed51da07efd17c64cc8dd5aef8f3e4
DIST qtbase-everywhere-src-5.15.2.tar.xz 50179672 BLAKE2B 0e4bdaab43cf59664bde89f87ea260c39acc2ef866d8629d41d9c326cab0ab68bcd943c86a472ae74bc9fb0b7ad50795ccb66275bb6b77d1fcf0a38b5662cb42 SHA512 a549bfaf867d746ff744ab224eb65ac1bdcdac7e8457dfa379941b2b225a90442fcfc1e1175b9afb1f169468f8130b7ab917c67be67156520a4bfb5c92d304f9
diff --git a/dev-qt/qtxml/qtxml-5.15.2.ebuild b/dev-qt/qtxml/qtxml-5.15.2.ebuild
index 57acaeaa59ae..140dd50a8a60 100644
--- a/dev-qt/qtxml/qtxml-5.15.2.ebuild
+++ b/dev-qt/qtxml/qtxml-5.15.2.ebuild
@@ -2,10 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
@@ -27,3 +29,5 @@ QT5_TARGET_SUBDIRS=(
QT5_GENTOO_PRIVATE_CONFIG=(
:xml
)
+
+PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012