summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-25 15:31:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-25 15:48:44 +0200
commit7b0dfb552380a1dbdf0cb090b33b7449489a23ac (patch)
tree38d201dba97846cd6e00907859d6e5d183fb1025 /dev-ros/costmap_2d
parentdev-ros/clear_costmap_recovery: Bump to 1.15.2. (diff)
downloadgentoo-7b0dfb552380a1dbdf0cb090b33b7449489a23ac.tar.gz
gentoo-7b0dfb552380a1dbdf0cb090b33b7449489a23ac.tar.bz2
gentoo-7b0dfb552380a1dbdf0cb090b33b7449489a23ac.zip
dev-ros/costmap_2d: Bump to 1.15.2.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/costmap_2d')
-rw-r--r--dev-ros/costmap_2d/Manifest1
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/Manifest b/dev-ros/costmap_2d/Manifest
index 7214e3ac5d1e..1130f354eeda 100644
--- a/dev-ros/costmap_2d/Manifest
+++ b/dev-ros/costmap_2d/Manifest
@@ -1 +1,2 @@
DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
diff --git a/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild b/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild
new file mode 100644
index 000000000000..afb1c245ae4e
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl:=
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"