summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 15:16:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 16:26:55 +0100
commit86155b599c5599a84831e1893214f65f3132a9e4 (patch)
tree7eb6559ad25533aedf4d90bdb68f228c67a43627 /dev-ros/image_cb_detector
parentdev-ros/laser_filters: Backport upstream patch to fix build in C++11 mode. (diff)
downloadgentoo-86155b599c5599a84831e1893214f65f3132a9e4.tar.gz
gentoo-86155b599c5599a84831e1893214f65f3132a9e4.tar.bz2
gentoo-86155b599c5599a84831e1893214f65f3132a9e4.zip
dev-ros/image_cb_detector: Fix build in C++11 mode.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/files/c11.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild2
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-9999.ebuild2
3 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/image_cb_detector/files/c11.patch b/dev-ros/image_cb_detector/files/c11.patch
new file mode 100644
index 000000000000..bddbce93725f
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/c11.patch
@@ -0,0 +1,13 @@
+Index: image_cb_detector/src/rgbd_cb_detector_action.cpp
+===================================================================
+--- image_cb_detector.orig/src/rgbd_cb_detector_action.cpp
++++ image_cb_detector/src/rgbd_cb_detector_action.cpp
+@@ -143,7 +143,7 @@ public:
+ for(size_t i = 0; i< features.image_points.size(); i++){
+ geometry_msgs::Point pixel = features.image_points[i];
+ float depth = *(depth_ptr+width*(unsigned int)pixel.y+(unsigned int)pixel.x);
+- if ( isnan(depth) )
++ if ( std::isnan(depth) )
+ {
+ continue;
+ }
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 972abdce8d2f..59b223affa7d 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
index 972abdce8d2f..59b223affa7d 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )