summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:45:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:45:21 +0200
commit567237c2b0b06e6a7a4dbc430b853e6845cf619d (patch)
tree0bf3d1d81f4ef06cf628a047cbd2b1cec4d57884 /dev-ros/message_to_tf
parentros-meta/vision_visp: Initial import. Ebuild by me. (diff)
downloadgentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.tar.gz
gentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.tar.bz2
gentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.zip
dev-ros/message_to_tf: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/message_to_tf')
-rw-r--r--dev-ros/message_to_tf/Manifest1
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild24
-rw-r--r--dev-ros/message_to_tf/message_to_tf-9999.ebuild24
-rw-r--r--dev-ros/message_to_tf/metadata.xml5
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/message_to_tf/Manifest b/dev-ros/message_to_tf/Manifest
new file mode 100644
index 000000000000..bb99c54d8331
--- /dev/null
+++ b/dev-ros/message_to_tf/Manifest
@@ -0,0 +1 @@
+DIST hector_localization-0.2.0.tar.gz 70999 SHA256 e0b01a8d1d285086e4bb738346f5d37ce188f12197bb10e75d66ac0770fc2f18 SHA512 5eab4f1861bbf1f755595700b9cb7e7f3fd1231ac9fe95f7a6f9f22c6d96045ebcecdf01b81464888b8a263fab585eb7d19682b1cc5aab6fa8809f25e7913739 WHIRLPOOL af642d3458d380c18985aa88e10625b4e7f0ae94a8bfaf9d8d4f1e38fa764785a9c95d551c4b0412c0c91649d8d3768a8cc4774fa761b8fce6ca7d21db374dd7
diff --git a/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
new file mode 100644
index 000000000000..4c0669f4be85
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/message_to_tf-9999.ebuild b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
new file mode 100644
index 000000000000..4c0669f4be85
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/metadata.xml b/dev-ros/message_to_tf/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/message_to_tf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>