summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:27:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:52:45 +0200
commite39cf95480d4b15353c879d12fc4f9ff2b7ccc7c (patch)
tree243219b816021ae15d09b3e23089db1f00071a8f /dev-ros/pluginlib
parentdev-ros/class_loader: Initial import. Ebuild by me. (diff)
downloadgentoo-e39cf95480d4b15353c879d12fc4f9ff2b7ccc7c.tar.gz
gentoo-e39cf95480d4b15353c879d12fc4f9ff2b7ccc7c.tar.bz2
gentoo-e39cf95480d4b15353c879d12fc4f9ff2b7ccc7c.zip
dev-ros/pluginlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pluginlib')
-rw-r--r--dev-ros/pluginlib/Manifest1
-rw-r--r--dev-ros/pluginlib/metadata.xml5
-rw-r--r--dev-ros/pluginlib/pluginlib-1.10.1.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-9999.ebuild27
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
new file mode 100644
index 000000000000..f8240c44048d
--- /dev/null
+++ b/dev-ros/pluginlib/Manifest
@@ -0,0 +1 @@
+DIST pluginlib-1.10.1.tar.gz 17109 SHA256 239591f5eb263e48769942feb125c46a56ae3e226dc3ef4bf5dfa39ab94c47e1 SHA512 0318b2893b100d0dddce3eac029e907bcfc759525bfc17de5c42f8d55facaf9c24f162df7baf4d4ed13ea9dcdaee06c85f730507fba6fbe8218b283e10ec6122 WHIRLPOOL 901c7f4b41abc708a00292d00f9f4e22d0c7f03e3ade900389bae8c436b93406110686f44a8a3380a13f7dd9ab4f79cc639f8ed494bccee49f91a4bfa1a48e1a
diff --git a/dev-ros/pluginlib/metadata.xml b/dev-ros/pluginlib/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/pluginlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pluginlib/pluginlib-1.10.1.ebuild b/dev-ros/pluginlib/pluginlib-1.10.1.ebuild
new file mode 100644
index 000000000000..6cdc9d6f509e
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.10.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD Boost-1.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/class_loader
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/pluginlib/pluginlib-9999.ebuild b/dev-ros/pluginlib/pluginlib-9999.ebuild
new file mode 100644
index 000000000000..6cdc9d6f509e
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD Boost-1.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/class_loader
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"