summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 08:42:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:46 +0100
commite3bc44bb44532ebd135f5f22cbb60785f973494c (patch)
tree383dd7c76d250ad55c026934f42a89f8e78d8617 /dev-ros/qt_gui
parentros-meta/rqt_common_plugins: Bump to 0.4.6. (diff)
downloadgentoo-e3bc44bb44532ebd135f5f22cbb60785f973494c.tar.gz
gentoo-e3bc44bb44532ebd135f5f22cbb60785f973494c.tar.bz2
gentoo-e3bc44bb44532ebd135f5f22cbb60785f973494c.zip
dev-ros/qt_gui: require qt5, not 4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/qt_gui')
-rw-r--r--dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild24
-rw-r--r--dev-ros/qt_gui/qt_gui-9999.ebuild4
2 files changed, 26 insertions, 2 deletions
diff --git a/dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild b/dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild
new file mode 100644
index 00000000000..e5f5859d5d2
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/qt_gui/qt_gui-9999.ebuild b/dev-ros/qt_gui/qt_gui-9999.ebuild
index f5ef4e6552d..e5f5859d5d2 100644
--- a/dev-ros/qt_gui/qt_gui-9999.ebuild
+++ b/dev-ros/qt_gui/qt_gui-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-qt/qtcore:4
+ dev-qt/qtcore:5
dev-python/rospkg[${PYTHON_USEDEP}]
>=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
"