summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-06 09:07:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 09:07:21 +0200
commit4ab06080629e5ea001cbe849067c9cdaa8ec5def (patch)
tree9b56c05e6091d2806b414629e1975381ba955124 /dev-ros/qt_gui_py_common
parentdev-ros/qt_gui_cpp: Bump to 0.3.6. (diff)
downloadgentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.tar.gz
gentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.tar.bz2
gentoo-4ab06080629e5ea001cbe849067c9cdaa8ec5def.zip
dev-ros/qt_gui_py_common: Bump to 0.3.6.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/qt_gui_py_common')
-rw-r--r--dev-ros/qt_gui_py_common/Manifest1
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/Manifest b/dev-ros/qt_gui_py_common/Manifest
index 7267dc3e096c..8e568934c8a7 100644
--- a/dev-ros/qt_gui_py_common/Manifest
+++ b/dev-ros/qt_gui_py_common/Manifest
@@ -6,3 +6,4 @@ DIST qt_gui_core-0.3.2.tar.gz 87326 SHA256 678e60f413ad455577ce0e76fa34f2603d0f7
DIST qt_gui_core-0.3.3.tar.gz 87422 SHA256 fc1bf4dfb3d357b38263d36023ee7b55a1799dfa437513ac51041c993e9cecd4 SHA512 5f2906e412b35b6edc9ba8792272b3d733574deda955279327e392ee3b0f55bb01a08607a25632fda43112842743fdd1432874fbf090f6b1404604c329b7dc3a WHIRLPOOL 6856cb3f58d6e68f1b3081ae4f2529f701a355fa5b0698f3191adc341da38fa3a47f17cd4cab459689e522aa7c4a117b0c86c62f39072711eb240234ee67dfe6
DIST qt_gui_core-0.3.4.tar.gz 87974 SHA256 09da32698c087a73bbf0dae2ce3b9f1d19beb5f56e15d2fd08009260589e27ef SHA512 794b0ea8b92cdbb748282ef48dcb41f24f3b83dd8ad92e8dc895d45ed085b9838b2ca4a5dc43284971d33b7ac40c86ca578fe042d71e0c9d1903cdfb561507af WHIRLPOOL 98b36b798b7dc57e88a5b59586015919c2f1d902dbde9352562237ec6cb6bb27d3fef296da1547949244b2deb0dc2e18a858ef2bb5021af1d64d76688f0b5a71
DIST qt_gui_core-0.3.5.tar.gz 90480 SHA256 ac6c4ea593fe69bc5227b5ccd607d74ba6e9310a9e5923d14db558082812e746 SHA512 1c307e220d8484013e83cf2e3e4b6d674db3d6273f08ffc1ab928f92c1a4009d3b3d8d011f88b40e73ad371be34c7d4a790a78a47361ddb1c44b1a44970bf955 WHIRLPOOL a70414fbbfea840b06f76b023753842593ea0ce0ad8a94ea728b52fad7a47c37b8afcf87f3fd22ab19e0d33323f96f2b06009272c722418a0cf742d5f28ede26
+DIST qt_gui_core-0.3.6.tar.gz 90705 SHA256 32c8ee990b6aca5d53a856071fb718fa6e92ffc4951e76df96496abeac75df8d SHA512 bdd824010552af098f2b9294aef18c73413a1f76fe1cf61daccf9d9f17d7d16f6a9a1ec11c157460c1b89d6c44f21fccbdcab813ca42c052a6bc46de52f86ab0 WHIRLPOOL d2ba2bb42580ca7639669e144766cf8e7411e1879c72cfed055c3e78e3caf1bc3a7a294cec2270c103e000c9ad334cb0b1da8f7d210c0fffa484d92194d60b19
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
new file mode 100644
index 000000000000..87a1c621b8d2
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"