summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-07 15:29:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-07 16:08:16 +0200
commit21173a62c13ebd00ba30e6a2d00de8807be0aeed (patch)
treec1cf2a711fffe384fc43ddddd3682fad5ebe87c8 /dev-ros/robot_state_publisher
parentdev-ros/xacro: Remove old (diff)
downloadgentoo-21173a62c13ebd00ba30e6a2d00de8807be0aeed.tar.gz
gentoo-21173a62c13ebd00ba30e6a2d00de8807be0aeed.tar.bz2
gentoo-21173a62c13ebd00ba30e6a2d00de8807be0aeed.zip
dev-ros/robot_state_publisher: bump to 1.13.6
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/robot_state_publisher')
-rw-r--r--dev-ros/robot_state_publisher/Manifest1
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.13.6.ebuild33
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild5
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-ros/robot_state_publisher/Manifest b/dev-ros/robot_state_publisher/Manifest
index 394bb14aff71..0207afd4de30 100644
--- a/dev-ros/robot_state_publisher/Manifest
+++ b/dev-ros/robot_state_publisher/Manifest
@@ -1 +1,2 @@
DIST robot_state_publisher-1.13.5.tar.gz 25346 BLAKE2B bdc7ed15178cdd8a8571796236b5273666f58486b831374254b45b79549d8b224097cb78c4585cb136f74bd4fee8309dfdef6dbaa03038acc126b35a4e2899dc SHA512 2ce97e35a64f9c6f8539780d2dabf416906da8144b579b07214b55e935aec3105f2087c90796ceb896f8766c46c2c2b72aaf9fdc4cfc80dd1b3f06b477acf778
+DIST robot_state_publisher-1.13.6.tar.gz 25885 BLAKE2B 0d673ef6cce53ff66a522de02ddeb93876d168a65cf102de2c0384f69911d9dfedf1cadba67e7251ed0ccdc7bf07b545c2ded5620419a970bbcf6fb63c9fcd15 SHA512 c0dbdd9149a1b308c29de1509641691d488aa0cd6b325d1245cbb16b537bbd3abf0c5e85ecd1c24a78117b6e45a833a45769c6619a22bfc7a1f5f7709071b21a
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6.ebuild
new file mode 100644
index 000000000000..b1afbf659735
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+ dev-ros/tf
+ dev-ros/urdf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
index 508dcb8c0b07..b1afbf659735 100644
--- a/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -29,6 +29,5 @@ RDEPEND="
dev-libs/boost:=
"
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
- test? ( dev-cpp/gtest )
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )
"