summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:32:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit5477396c0367823ead2347626f80296f1ded98ac (patch)
tree253f0c2991f5b9b140d8984f032c809dfea4d7c2 /dev-ros/rosconsole
parentdev-ros/rosbag_storage: Bump to 1.11.15. (diff)
downloadgentoo-5477396c0367823ead2347626f80296f1ded98ac.tar.gz
gentoo-5477396c0367823ead2347626f80296f1ded98ac.tar.bz2
gentoo-5477396c0367823ead2347626f80296f1ded98ac.zip
dev-ros/rosconsole: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rosconsole')
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.11.15.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index 84bda7639707..898e47a6b524 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
+DIST ros_comm-1.11.15.tar.gz 946139 SHA256 532b8cc764e9ca8765484a4468b8537c1ddd84342896267cf3e9f6b19c1b7203 SHA512 8eea3fc948093a7640851f18856f2a20748afb80f935e28d230dc2095956d753bde5081dcd020d09638d9c5d63e031257515b6c6874286c03737507e67cce270 WHIRLPOOL 5e0a971f4312dce99c2e2c11841445cea999dbe5b1ebde3ce26badb9a7eaf9fb84220ed5d1e0088e85835104ddad3cd4d555708d010f83da6e84d257bafe699b
diff --git a/dev-ros/rosconsole/rosconsole-1.11.15.ebuild b/dev-ros/rosconsole/rosconsole-1.11.15.ebuild
new file mode 100644
index 000000000000..7d1cc2938086
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.11.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}