summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-17 12:17:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-17 13:46:31 +0200
commitdf508f5daa9c5f51cd4e44684bf22666c21cea80 (patch)
treebb7bfe8ebf4d02ef21dda3d91debbfb54e5d99ef /dev-ros/roscpp/roscpp-1.13.2.ebuild
parentdev-ros/topic_tools: Bump to 1.13.2. (diff)
downloadgentoo-df508f5daa9c5f51cd4e44684bf22666c21cea80.tar.gz
gentoo-df508f5daa9c5f51cd4e44684bf22666c21cea80.tar.bz2
gentoo-df508f5daa9c5f51cd4e44684bf22666c21cea80.zip
dev-ros/roscpp: Bump to 1.13.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/roscpp/roscpp-1.13.2.ebuild')
-rw-r--r--dev-ros/roscpp/roscpp-1.13.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/roscpp/roscpp-1.13.2.ebuild b/dev-ros/roscpp/roscpp-1.13.2.ebuild
new file mode 100644
index 000000000000..277ba479468a
--- /dev/null
+++ b/dev-ros/roscpp/roscpp-1.13.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"