summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:45:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:45:00 +0200
commitaa7c211222aa57c5b25278a62a6b9f60e59bab7e (patch)
treed3722bb53d6b29aba8c451376c7d1b779d931e81 /dev-ros/roscpp_tutorials
parentdev-ros/turtlesim: Initial import. Ebuild by me. (diff)
downloadgentoo-aa7c211222aa57c5b25278a62a6b9f60e59bab7e.tar.gz
gentoo-aa7c211222aa57c5b25278a62a6b9f60e59bab7e.tar.bz2
gentoo-aa7c211222aa57c5b25278a62a6b9f60e59bab7e.zip
dev-ros/roscpp_tutorials: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/roscpp_tutorials')
-rw-r--r--dev-ros/roscpp_tutorials/Manifest1
-rw-r--r--dev-ros/roscpp_tutorials/metadata.xml5
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-0.6.1.ebuild27
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-9999.ebuild27
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/roscpp_tutorials/Manifest b/dev-ros/roscpp_tutorials/Manifest
new file mode 100644
index 000000000000..b0543368940a
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/Manifest
@@ -0,0 +1 @@
+DIST ros_tutorials-0.6.1.tar.gz 126792 SHA256 0227557d49343c8dc2c17f5fba6a44ca8fe46cb0d9f34315bf4c2f8c3d9969f5 SHA512 f09e5451030c0a76a9473020535e79ac06e748f4208109cf83e61526d13472c3390402814a3d145cb793c5418af703cd9959ca57143798d1706185c13d3418c5 WHIRLPOOL 861fec5410f5e1f6930b537f757abf120ee5b10b843a39010e0dc04f170c627c793dbf462fa1ac0a2c3f150780915d01ade459f973453a053ee53e2ccae7d795
diff --git a/dev-ros/roscpp_tutorials/metadata.xml b/dev-ros/roscpp_tutorials/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-0.6.1.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.6.1.ebuild
new file mode 100644
index 000000000000..5313d6fef602
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-9999.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-9999.ebuild
new file mode 100644
index 000000000000..5313d6fef602
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"